nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   Fedora, nvnet and optimization=1 equals frequent lockups (http://www.nvnews.net/vbulletin/showthread.php?t=22976)

nry 01-01-04 02:49 PM

Fedora, nvnet and optimization=1 equals frequent lockups
 
Hi all,

After reading through all forum postings regarding the nvnet network card driver I found that my problem was not uncommon. I have an ASUS A7N266-VM motherboard which is nForce 2 based, running the latest BIOS.

I am running the stock Fedora install (though all updates including kernel make no difference to the problem). I found that as soon as I install the nForce drivers system performance drops substantially when the network is on use. Considering this box is a firewall/web server/cache/file server for my home LAN this isn't much good!

It seems that the use of 'options nvnet optimization=1' in /etc/modules.conf makes system performance buttery smooth. Good except I now experience severe and very frequent system hangs either during boot or at random times during system usage.

I have installed the 256 nForce drivers from source, and have tried older versions which all have the same issue.

The main problem is that once I make the change to modules.conf, if the system cannot be booted successfully there is no way for me to change this file back to default.

Can anyone else here suggest anything I can try? I am currently running without the modules.conf alteration as this is at least stable. I notice that although the poor performance of the nvnet driver has been reported by lots of people, NVIDIA have not updated the nForce driver set for months and months. I'm now very close to ditching the board in favour of a non-NVIDIA board as I am not willing to live with the poor performance. Things like Squid, named, Apache etc hog between 30-100% of the CPU though with the optimization=1 line added they rarely go above 5%: that's when it doesn't hang during boot!

I'm giving this a few days to try some suggestions and if it isn't resolvable I'll be buying a new board and steering clear of NVIDIA in the future!

Regards and thanks for any replies,

nry

nry 01-02-04 11:12 AM

Well, after hours of playing around with drivers, installs etc etc I've ordered a new board with no nVidia stuff in sight.

I installed Fedora thinking it was faster than Red Hat 9 (which in some ways it is) but it turns out the reason RH was slow was the nvnet drivers, hence Fedora is no better.

I'd still be interested in anyones comments on this issue, and have e-mailed the nforce-bugs with details of the issue.

Regards,

nry

netviper13 01-02-04 06:04 PM

Try installing kernel 2.6, as it has an open-source "nVidia" driver that's supposedly pretty good.

dnoyeB 01-05-04 08:55 AM

Try using the 256 drivers. or what was suggested in the other thread, use the 261 drivers, but replace the nvnet part with the 256 nvnet before you issue the make command. That is what I have done and my system is running flawlessly.

261 nvnet is total garbage any way you configure it.

nry 01-05-04 09:02 AM

I haven't mentioned this in this current posting, but the nvnet drivers for 0256 and 0261 are exactly the same as far as I can tell. All files are dated within the text of the files at the same date of March 13th (I think) 2003. I can't see any differences and the main diff between 0256 and 0261 is that the 0261 driver package has an 'nvgart' folder alongside the 'nvaudio' and 'nvnet' folders of the 0256 set.

Regards,

nry

dnoyeB 01-05-04 09:21 AM

They appear to be the same because they almost are. Remember this is a proprietary driver, so the differences are not in the text files which are all the same and basically there for compilation, but the difference appears to be in the binary file, as one would expect with a non-source based driver.

check nvnetlib.o

Besides, to put it bluntly "it works." I learned through 1 week of headbanging. You can feel free to do the same if you wish ;)


I shoudl also add that optimization=1 is a cop-out considering that its also available in the 256 drivers. Which kernel are you running, RH8 or RH9, or what? I thought 256 would not compile under RH9 anyway.

nry 01-05-04 02:00 PM

I got mixed up slightly as yes, the nForce driver files are nothing to do with the binary!

I'm running Fedora Core 1, though I'm fairly sure that I used the 256 drivers under RH9 on a previous install on this box. Can't be quite sure though!

I'll maybe try the 256 drivers under Fedora for future reference!

Cheers for the replies,

nry

dnoyeB 01-05-04 03:35 PM

Well one of the updates in the 261 package listed something to the affect of making changes so it would compile under RH9. So I just assumed 256 would not, but I am not sure I tried it.

so I downloaded the "source" form 256 and 261. cut and paste the nvnet subfolder from 256 into 261. then compile and install the new combined driver. no problems even without the optimization=1 line.


All times are GMT -5. The time now is 05:48 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.