nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Mandrake 9.2 and NVidia 1.0-5328 (http://www.nvnews.net/vbulletin/showthread.php?t=22980)

Nowhere_Man 01-01-04 04:29 PM

Mandrake 9.2 and NVidia 1.0-5328
 
1 Attachment(s)
Ok, Im using Mandrake 9.2 with 2.4.22-10mdksmp, a Geforce4 MX 440 (64MB), ECS motherboard (L4VXA2) w/P4X400 North and VT8233A southbridge. 512 MB DDR. This is a clean install and works perfectly with the nv driver.

When I ran the Nvidia installer everything installed fine and the kernel moduals load fine. When I type startx the screen goes blank and seems to try to display the Nvidia splashscreen but stays black. There is a video signal being sent to the monitor because the power light stays green. ALT-Ctrl-Bcksp does not work. Neither does Alt-Ctrl-+/-. It seems from looking at the /var/log/XFree86 log that it might be something with the display but I'm not sure at this point. I am Attaching the log file, and my XF86 config file. Any help would be appreciated. Let me know if you need more info. I know the XFconfig file lists nv driver. That is so I could get here to post. I did change the nv to nvidia.

Thanks,
Charlie

XF86config-4

# File generated by XFdrake.

# ************************************************** ********************
# Refer to the XF86Config man page for details about the format of
# this file.
# ************************************************** ********************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "en_US"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "1280x1024 @ 60 Hz"
HorizSync 30-70
VertRefresh 50-120

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce4 (generic)"
Driver "nv"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 15
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 16
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 24
Virtual 1280 1024
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
Screen "screen1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
EndSection

gorgon 01-01-04 05:48 PM

i had the same problem
you have to change this

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce4 (generic)"
Driver "nv"
Option "DPMS


to this

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce4 (generic)"
Driver "nvidia"
Option "NvAgp" "0"

that should fix ur problems

fernandezm 01-01-04 11:45 PM

Confirmed, it works now!
I had exactly the same problem, and changing my old 4496's driver value (Nvagp "3") to "0", make 5328 drivers WORK!!! :D

Thanks
Marcelo

BrianzaMan 01-02-04 06:17 AM

Yes , you solve the problem with NvAGP "0" , but you get the AGP Disabled !!

I think that is better for you (and for me too) to revert to the previous version of the driver :)

Bye

Marcello

Nowhere_Man 01-02-04 08:20 AM

Ok, I put the Option "NvAgp" "0" in and got the same thing. Should I remove the Option for DPMS? I noticed a thread where he put Option "ConnectMonitor" "DFP". What would mine be? "CRT"

HELP!!!

Thanks,
Charlie

fernandezm 01-02-04 10:35 AM

Mmmm... you're right, I did a 'cat /proc/driver/nvidia/agp/status' and it shows disabled....
Then I tried with "Nvagp" "1" and I got the same error...
Tried with "Nvagp" "2" and it works... this is the agp status now:

[root@localhost marcelo]# cat /proc/driver/nvidia/agp/status
Status: Enabled
Driver: AGPGART (inactive)
AGP Rate: 8x
Fast Writes: Disabled
SBA: Disabled
[root@localhost marcelo]#

But looking at /var/log/XFree86.0.log (~ line 472):

[24] -1 0 0x0000b400 - 0x0000b4ff (0x100) IX[b]
[25] -1 0 0x0000d800 - 0x0000d81f (0x20) IX[b]
[26] -1 0 0x0000b800 - 0x0000b8ff (0x100) IX[b]
[27] -1 0 0x0000d000 - 0x0000d007 (0x8) IX[b]
[28] -1 0 0x0000d400 - 0x0000d407 (0x8) IX[b]
[29] 0 0 0x000003b0 - 0x000003bb (0xc) IS[b](OprU)
[30] 0 0 0x000003c0 - 0x000003df (0x20) IS[b](OprU)
(WW) NVIDIA(0): Failed to verify AGP usage
(II) NVIDIA(0): Setting mode "1024x768"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(**) NVIDIA(0): Option "BackingStore" "true"

So.... I don't know if I have AGP enabled or not... :D
What thing should I believe???:

Thanks
Marcelo


All times are GMT -5. The time now is 03:06 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.