nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   blackscreen/freeze on X (http://www.nvnews.net/vbulletin/showthread.php?t=23028)

ltal 01-02-04 08:55 PM

blackscreen/freeze on X
 
Athlon XP1700+
Biostar M7MIA motherboard
HPT370 onboard IDE controller (installed on this)
Geforce 4 Ti4200 AGP 128MB
SBLive Value
Dell 1901FP monitor
Gentoo linux kernel 2.6.0

I've tried many different versions of the nvidia-kernel and nvidia-glx drivers.
No errors come out of X, although I have some strange behavior in my messages log. I get no splash screen, no nothing, X simply refuses to load and the system hard locks (while using the nvidia driver).

I know there have been problems with 5328 so I rolled back to 4496.

When I try to use the 'nv' driver I get a complaint about being unable to setup the write-combining region. X sort of loads, I get no splash screen or hatched background but twm comes up very large (looks like 640x480) and I have no mouse cursor, but windows take focus and I can get the twm menu, although clicking 'exit' only removes the window headers and I have to ctrl-alt-bksp to get out of X and there are two copies of the message saying X was forcibly killed.

Help? It's been a week and I still have no X, it's really starting to hurt. Thanks in advance. -Justin

Cut from messages, first the login and crash, then the reboot to show dmesg:

/var/log/messages
XFree86.0.log

Kernel config
(I have added support for my AMD 761 chipset and removed ACPI as well, not reflected in this file)
XF86Config

whig 01-03-04 10:25 PM

Just a small thing to point out but:

Your nVidia X driver is being loaded without you having a Load "nvidia" in the Modules section of your XF86Config.


All times are GMT -5. The time now is 09:31 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.