nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Fedora, Tnt2 and drivers 1.0-5328 (http://www.nvnews.net/vbulletin/showthread.php?t=23040)

lumiere 01-03-04 06:07 AM

Fedora, Tnt2 and drivers 1.0-5328
 
Hello, I have a strange problem with my Tnt2 and Fedora. I have installed the las drivers, but when I boot Linux, the system don't switch to the graphic mode during the startup "Detail screen". I see a black screen. It's switch to the graphic mode only before the login.

I see the nvidia logo and the screen appear ok.

The only problem is before the login screen. It's like the system load the video driver after the detail startup.

Please anyone has a solution?

Thanks in advance
Enrico

Chris Harden 01-03-04 11:58 AM

Howdy,
I have Fedora core 1 as well, and a GeForce Ti 4200 - and get exactly the same problem. If it is the same problem, it seems to be caused the first time X is started, as if you boot to a console, login, then run startx from there, the first time you run it, it will die, but if you run it a second time it runs fine.

I also get about 4 frames per second on glxgears, do you have slow GL or is it an unrelated problem? I also noticed that when I run xdpyinfo, NVIDIA-GLX is missing, yet GLX and NV-GLX are both there, although according to the 'installed files' section in the README supplied with the drivers, all my symlinks are there.

I've attached my X log, any help would be most appreciated.

Chris Harden 01-03-04 11:59 AM

doh
 
1 Attachment(s)
ok, NOW ive attached my log.....I hope

HammerLi 01-03-04 10:04 PM

Add this to your /etc/X11/XF86Config:

Section "Device"
...
Option "NvAGP" "1"
EndSection

Chris Harden 01-04-04 04:28 AM

Thanks for the reply, however adding that line prevents X from starting at all, and my system became as fast and stable as a 286 running win95 (and for some reason my consoles lost the ability to scroll or have a little blinking cursor) :/ putting it as 2 gives the same problem as before.

lumiere 01-04-04 07:42 AM

I have the same conseguences after adding the line.
Same problem

Enrico

lumiere 01-05-04 03:46 AM

Please, anyone has a solution?

Thanks
Enrico

Chris Harden 01-07-04 09:02 AM

Well, im not exactly a linux guru, but i know a bit, I've been digging thru my system, but dont know enough about linux to know whats right and wrong, maybe if we compare things, work out the common fsck up we will hit a solution? my ICQ# is 61262951 and my MSN is byte.slammer@ntlworld.com (although MSN is a bit unreliable at the mo) if you want to get in touch and work on this.

lumiere 01-07-04 09:16 AM

I have solved the problem using this drivers:

http://www.sh.nu/download/nvidia/linux-2.4/

Bubu


All times are GMT -5. The time now is 04:10 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.