nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   GeForce4 MX 440 and Mandrake 9.2 Problems (Black Screen) PLEASE HELP (http://www.nvnews.net/vbulletin/showthread.php?t=23147)

Nowhere_Man 01-05-04 06:26 PM

GeForce4 MX 440 and Mandrake 9.2 Problems (Black Screen) PLEASE HELP
 
1 Attachment(s)
I REALLY need some help getting these drivers running. I've never had trouble with them before until I built this new system. No matter what I have tried or which driver version I use, I get the same thing, a blank screen, or a thin white and blue jumbled band along the bottom 3rd of the screen when using the smp kernel.

Ok First System Specs.

Intel Pentium 4 2.5GHZ
ECS L4VXA2 motherboard with via PX400 chipset
512 MB PC3200 DDR
Soundblaster live
Evga GeForce 4 MX 440 with dual monitor outputs
Clean install of Linux Mandrake 9.2 running 2.4.22-10mdk kernel with sources installed.
Boots and runs fine with nv driver.

Now, I install the Nvidia drivers version 1.0-4496-pk2.run

Installer log output to /var/log is:

Nowhere_Man 01-05-04 06:28 PM

Continued
 
1 Attachment(s)
So, I assume that the driver install is fine and edit my XFree86config file to read: See Attachment

And type ?startx?. Then the monitor click and tries to display as usual but all I get is a black screen. Ctrl-alt-+/-, ctrl-alt-bckspc, and crtl-alt-Fx do not work, so I reboot.

Nowhere_Man 01-05-04 06:33 PM

Continued
 
1 Attachment(s)
The output of the Xfconfig log in /var/log is : See Attachment

Nowhere_Man 01-05-04 06:35 PM

Continued
 
1 Attachment(s)
So, from the output NVIDIA(0): AGP 4x successfully initialized. I know AGP 4X is working and that the kernel and GLX modules loaded fine. But, most discussions on this board with this problem state to put in Option ?NvAGP? ?0?. So I try that....

The output of the log file is.....

Nowhere_Man 01-05-04 06:40 PM

Finishing up
 
And the outcome is the same, a black screen, and reboot. What else can I try? Any ideas? Need more information? Please help, I love Nvidia cards, but they need to run. I'm sure in the end this is something simple that I'm just not aware of. I have read through, printed out, and nearly memorized the Nvidia installer read me and installation guide. I have seen many posts on this board with the same problem, but their solutions dont seem to work for me.

Thanks for any help in advance. My email address is nowhere_man@sbcglobal.net if you need more info.

Thanks,
Charlie

Nowhere_Man 01-05-04 07:31 PM

Ok, got it right after I posted. I had this card in my old computer with APCI enabled, so I assumed it wasnt the cause in this case. I had disabled it in Lilo, but not in the cmos prior with no change. On a whim, I disabled it in CMOS and Lilo and BANG, booted right in.

Hope this all helps someone else. Is it worth upgrading to 1-5xxx drivers? Maybe in a day or so, maybe not. Just glad it's running after nearly a week of trying.

Charlie

Regman 01-30-04 03:45 PM

Thanks Nowhere_Man!

Adding the line append="noapic" to /etc/lilo.conf finally worked for me and I tried everything. I too also have a Geforce4 MX400 and the ECS L4VXA2 motherboard. However, I am running Debian with a custom 2.4.24 kernel.

For those that try adding this to their /etc/lilo.conf, make sure you run /sbin/lilo afterwards. I made that mistake of not running it and cost me a few more hours of head banging frustration.

Regman


All times are GMT -5. The time now is 04:27 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.