nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   XMMS: libGL.so.1: cannot handle TLS data (http://www.nvnews.net/vbulletin/showthread.php?t=23177)

anubis-c7 01-06-04 11:49 AM

XMMS: libGL.so.1: cannot handle TLS data
 
Hi
I am running Debian (sid) and tried xmms with
v4496 and 5328 of NVidia-Driver[....].run .. But xmms complains about "libGL.so.1.: cannot handle TLS data"... And all the openGL-Visualisation-Plugins are "gone".

What can I try to solve...? Thank you for every idea....

NV15- Geforce2GTS

anubis-c7 01-06-04 05:02 PM

Now I tried to compile xmms1.2.8.tar.bz myself but 'make' reported a
libtool: link: 'usr/lib/libGL.la' is not a valid libtool archive

It's the driver again ;( ... This happens for me with the .tar.bz archive and with the recent cvs built too... (pb)

What could this be?
-----------------------
update:
What strange thing.. I did a ./NVIDIA-[...]5328-pkg1.run --extract-only after that a 'make' and a 'make install'

After that I CAN compile the xmms.1.2.8.tar.bz and the CVS -checkout too... BUT: Now I have the failure: "libGL.so.1 Cannot handle TLS-data" again (--> see posting no1) :mad:

dpw2atox 01-06-04 07:14 PM

try using beep instead......its a gtk2 port of xmms and works fine with the new drivers.

http://beepmp.sourceforge.net


I recomend the cvs as it has many fixes from 0.9.6.1. Im running it now and its great.

anubis-c7 01-07-04 01:09 PM

Hi

I tried beep-media-player and indeed - error was gone -- BUT when I install any of the openGL-Plugins then I have the same problem...

libGL.so.1 cannot handle tls data

When I rename the folder /usr/lib/tls to tls.old then I can start xmms (or beep) and see the openGL plugins - which work but not properly when I do <enable> <disable> the Plugin - then I get a "segmentation fault... "

Quote:

(gdb) run
Starting program: /usr/bin/xmms
(no debugging symbols found)...(no debugging symbols found)...[New Thread 16384 (LWP 16683)]
[New Thread 32769 (LWP 16685)]
[New Thread 16386 (LWP 16686)]
[New Thread 32771 (LWP 16688)]
[New Thread 49156 (LWP 16689)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 16384 (LWP 16683)]
0x4072fd47 in ?? () from /usr/lib/libGL.so.1
(gdb)
------------
(gdb) bt
#0 0x4072fd47 in ?? () from /usr/lib/libGL.so.1
#1 0x08206920 in ?? ()
#2 0x081d5b58 in ?? ()
#3 0x08215798 in ?? ()
#4 0x40d5d000 in ?? ()
#5 0x40735778 in glXChannelRectSyncSGIX () from /usr/lib/libGL.so.1
#6 0x08206920 in ?? ()
#7 0x082068f0 in ?? ()
#8 0x08206920 in ?? ()
#9 0x081d5b58 in ?? ()
#10 0x08206920 in ?? ()
#11 0x40730ee1 in ?? () from /usr/lib/libGL.so.1
#12 0x08206920 in ?? ()
(gdb)
for me it seems first the /usr/lib/tls/libGL.so.1 is used and after it didn't found it due renaming it used the /usr/lib/libGL.so.1 what caused the segmentaion fault :(

greetings

Valheru 01-07-04 02:32 PM

The 5328 GLX driver appears to be borked - at least, a lot of people are having a problem with them, myself included. The Gentoo dev team released a modified ebuild a few days ago that apply a few patches to the drivers before installing them. Now I can start X without recieving error messages about GLX and TLS data but X jsut starts with a black screen and all the log says is right after initialising the GLX extention it catches a Signall 11 and exits. :mad:

anubis-c7 01-09-04 07:57 AM

Hi

Finally I tried 4496/5328 nvidia installers, but I also tried nvidia-glx (4496) debian-package. I also tried different parameters like '--force-tls=[classic/new]' but no success..
I upgraded to Kernel-2.6. and these TLS errors are gone. But I still have the 'segmentation faults' upon 'enable'-'disable' ANY openGL plugin..

greetings


All times are GMT -5. The time now is 11:18 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.