nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   GLX fails to load (http://www.nvnews.net/vbulletin/showthread.php?t=23223)

prock 01-07-04 11:41 AM

GLX fails to load
 
1 Attachment(s)
Hello,

I have just compiled/installed on a debian unstable according to the instructions at:
http://home.comcast.net/~andrex/nvid...ian/index.html

note I am running v4496.

For some reason unless I have to remove the Load "glx" from my XF86Config to allow me to start X. Not surprisingly this leaves me with no GLX.

I've attached the X log from when it crashes (with Load "glx" enabled).

Any help would be greatly appreciated!

-Peter

prock 01-07-04 08:35 PM

solution
 
I have managed to solve this problem, here's what I did in case anyone else has the same problem:

My original nvidia source build .deb package (create with 'make-kpkg modules_image') was from the testing tree. I upgraded to the unstable tree (see http://home.comcast.net/~andrex/nvid...ian/index.html for info on how to do this, it took a little work). Then I:

rm -rf /usr/src/modules
grabbed the make-kpkg .diff from the site mentioned above (make sure to grab the unstable .diff, as there is one for testing and one for unstable).
rebuilt the module from scratch according to instructions, and installed over the existing .deb created from the testing sources.

I believe the problem had to do with the TLS problem that I've read about, but completely don't understand (or care to).

Another note: even after I got into X, as soon as I ran glxgears, my system locked up completely. Switching the NvAGP option to "1" from "2" in my XF86Config solved this.

Hope this helps someone.

-Peter


All times are GMT -5. The time now is 03:46 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.