nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   SAX2 Crash : GeForce4MX440 : kernel 2.4.20-athlon (http://www.nvnews.net/vbulletin/showthread.php?t=23296)

mitsch 01-09-04 12:08 PM

SAX2 Crash : GeForce4MX440 : kernel 2.4.20-athlon
 
1 Attachment(s)
Hi there!

Big problems around here since I updated my SuSE 8.2- System with YOU to a patched kernel with the package k_athlon-2.4.20_101.i568.rpm. Since than the hardware-acceleration doesn't work any more. If I try to activate it, sax2 may crash sometimes but if it crashes I can't get the system work anymore. I can't even shutdown via ssh?!? :(
Well, you may say: no matter! Why don't you just install the old kernel, anyway? I tried, but I can't get the acceleration work, either! Now, I'm afraid, my graphics-processor is broken...

O.K., I'll start at the beginning:
First I upgraded my system-kernel as I said. Then I started the NVIDIA-Linux-x86-1.0-4496-pkg2.run skript getting some strange failure-messages. O.K., "strange". The skript simply asked me if I had the right kernel-headers istalled, cause it wasn't able to compile a fitting kernel-module. To make it short: I have everything I need to compile a kernel: The kernel-sources, a c-compiler, ldconfig, whatever.
Then I downloaded another skript, it was NVIDIA-Linux-x86-1.0-5328-pkg1.run. First with no success. I tried it several times with other kernels (default SuSE-kernel, older patches, etc...), and it worked! ...until I used sax2 to activate the kernel-module (if I could activate 3D-acceleration - sometimes I couldn't (message: please install the nvidia-driver from the nvidia-homepage, though I have installed it a few minutes ago)): I had two different error-messages: The first was harmless

(EE) Screen(s) found, but none have a usable configuration.

Harmless, 'cause the system didn't crash. The other was something like

(EE) I don't use the 300 * 200 resolution

don't know, I have no log-file with this error message left on the harddisk, but sax2 was complaining about a very small resolution I really never wanted to use! The other is attached to this mail. Also my NOT-WORKING and my WORKING XF86.Config. Since I obviously can't attach more then one file, I copied it in one file!

Here's the rest of my system:

- video card: Leadtek WinFast A 170 DDR T (Nvidia GeForce 4 MX 440 SE - chip)
- driver version: NVIDIA-Linux-x86-1.0-5328
- distribution: SuSE Linux 8.2
- video bios revision: there is no /proc/driver/nvidia/cards/0 while X is running. Sorry!
- processor: AMD Athlon XP 1800+
- motherboard model: ASRock K7VT2

Hope you can help me...
By the way: How can I check, if my GPU's o.k. (without a working (=hardware-accelrated) X, of course)?

Mitsch

doublepanic 01-09-04 04:56 PM

Hi Mitsch,
I got the same problem with the 'missing athlon header files'.

Please read the following:

ftp://ftp.suse.com/pub/suse/i386/sup...ler-HOWTO.html

Maybe you have to reinstall the latest athlon kernel.

Hope you did not broke your gpu!!;-)

All the best,
Carsten


All times are GMT -5. The time now is 06:21 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.