nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   startx = blank screen (http://www.nvnews.net/vbulletin/showthread.php?t=23327)

pak9rabid 01-09-04 08:52 PM

startx = blank screen
 
1 Attachment(s)
hello all. mkay, here's the problem. I've installed the newest nvidia display drivers (version 5328) by using the .bin file. it says everything went ok (it had to build a kernel interface). Whenever I attempt to start the x server with the installed drivers n the appropriate XF86Config file mods, it goes into a black blank screen and does nothing. I cannot crtl-alt-backspace to kill the server, nor crtl-alt-del to reboot. Also, it does not generate a log file when i reboot the system (reset button) and check under /var/log. attached is my XF86Config file. anyone have any ideas what might be going on? Another interesting note, if i set the verbose level to 5 (startx -logverbose 5), upon rebooting from the lockup, if i look at the XF86Config file it's full of random characters.

System specs:
Distro: Gentoo 1.4
X Server: 4.3.0
CPU: Athlon-XP 2400+
vid: GeForce3 Ti 200

thanks

pak9rabid 01-09-04 09:28 PM

oh yea..i have an ECS K7S5A MB with the SiS 735 chipset.

whig 01-09-04 11:15 PM

Is this your first attempt at getting nVidia X drivers going? Or did a previous version work for you? The 5328 drivers don't work on this motherboard (a Via one) but I can make do with some older ones. Still waiting for AMD64 / kernel 2.6 compatibility too.

If it is your first attempt don't forget to modprobe the nvidia module.

Don't know what could be screwing up your XFConfig file. That is darn weird.

pak9rabid 01-10-04 11:41 AM

nah, this has been a reocurring problem for a looong time. i've even tried different distros (redhat, slack) and still the same problem. maybe i need to have the generic SiS apg chipset enabled when configuring the kernel to compile? (Character devicies->/dev/agpcart->SiS). I'm gonna give that a try.

jiml8 01-10-04 04:29 PM

I have just installed the latest drivers, and I also had to compile an interface. I tried to sh the .run module and gave up on that; I did an extract-only which constructed the directory NVIDIA-Linux-x86-1.0.5328-pkg1. I then did a cd into it and ran the installer.

I then discovered that the installer wouldn't place the nvidia.o module where it needed to be to be found by the kernel. I manually copied it over from the directory into which it was compiled, and away we went.

The module was compiled to here:

.../NVIDIA-Linux-x86-1.0-5328-pkg1/usr/src/nv/nvidia.o

meinzorn 01-11-04 01:16 AM

Hey, Hows it going, I just made this account because i've been trying to install these drivers as well, and i'm having the same problem.. I use an EPoX 8RDA+ mobo and have an Nvidia Geforce 4 MX440 video card.. someone told me to make sure that my sync rates were entered correctly.. I changed them and my problem then became different.. when I startx I now get this screen with a bunch of funny characters.. *sigh* its getting kinda annoying.

anyone want to help me at all? it woul be much appreciated, i'm pretty new at this stuff.. if you can contact me via AIM. I'm meinzorn on there as well.

once again, thank you if you can help me.

meinzorn 01-11-04 03:21 AM

OK! me and a friend of mine have been working at this problem for a long time. He read on a forum something about someone updating the bios to their computer and it working fine..

we figured why not give it a shot and update the bios... after the update it works perfect. just wanted to let you all know so that maybe you could give it a try.

peace out mofo's

pak9rabid 01-11-04 09:51 PM

got it working..yaaaaay!!
 
1 Attachment(s)
today is a happy day for mankind...well at least for this man. after 3 days of trying to get the nvidia drivers to work, i fiiiiiiiiinally got it. the fix?..well as always it was something easy/hard to figure out. i did a kernel recompile, only this time i made gd sure to enable agp support. if you go into the `Character devices' -> `/dev/agpgart (AGP support)', you'll notice a list of agp chipsets. all i had to do was enable the chipset that pertains to me (`Generic SiS Support') in my case. I put a yes on that suckah, did a recompile, n away I was. well, not at first. i went to fire up X, i was yet AGAIN getting the same problem (X would halt at a blank, black screen). fed up i decided to just leave the gd thing and go on a beer run. well, upon returning to my domain, i noticed something different..something reeeeeeally different. X was actually running. i ran quake3 just to make sure, n beautifully it ran. the only problem i had now was that it was taking it about 5 mins to load X. well sticking "Option" "IgnoreDisplayDevices" "DFP, TV" into my XF86Config file sure as hell fixed that problem up. gd..i feel like i just got laid for the first time. anywho, there it was. i think this is definately something NVIDIA should put into their readme file, seeing as this seems to be a popular problem among many people (the enabling AGP support in the kernel). anywho, im happy now...time to start playing with the various nvidia options in the XF86Config. see what this puppy can do.

Thanks everyone for the input!!

PS, attached is my config for anyone who's interested.

gerd 01-13-04 03:39 PM

same problem with 1.0-5328 - 1.0-4496 works
 
I had exactly the same problem with the newest version 1.0-5328. It's not even possible to get an XFree86.0.log. Then i tried version 1.0-4496 from the archive and it worked instantaneously.
GeForce4 Ti 4200. Kernel 2.4.23. Mobo Shuttle AK38N with Via KT400.
If only nvidia would make those drivers open source ...

pak9rabid 01-13-04 03:45 PM

heh, yea, i think that would be preferred, but prolly not gonna happen, seeing as how im sure nvidia would hate for people to see the secrets of their real-time compiler. specifically the limiting hardware performance section. kind of makes u wonder how nvidia has been able pull off a 50% performance increase with only a driver update. *cough detonator3 cough cough* :p


All times are GMT -5. The time now is 11:33 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.