nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   5328 & Toshiba Satellite P25-S507 fails (http://www.nvnews.net/vbulletin/showthread.php?t=23408)

snblitz 01-11-04 04:11 PM

5328 & Toshiba Satellite P25-S507 fails
 
Toshiba Satellite P25-S507, Linux 2.6.1, XFree86 Version 4.3.0, Nvidia driver 5328 fails.
There are no unusual messages in the logs, so the driver doesn't seem to know that things are not working.
Here is a picture of what I see upon starting X:
JPEG of messed up screen
It's the NVIDIA logo screen.
4496 works well.
If I install 5328 and startx I get the screen in the picture. If I rmmod the 5328 driver and then insmod 4496 & startx again, I get the same messed up screen. I have to reboot in order for 4496 to again correctly work.
Here are some more details:
XFree86.0.log
XF86Config

stefan42 01-12-04 05:57 AM

I made similar experiences with my P20 under Suse 8.2. My attempts to find somebody who has a Toshiba P20/P25 running sucessfully with 5328 failed so far. Let's hope for the next release...

snblitz 01-30-04 02:13 AM

5336 works
 
5336 version of the NVIDIA driver is working correctly.

stefan42 01-30-04 10:59 AM

Yes, I'm glad to say it works for me too!
The only bad thing I've noticed is an occasional flickering of the screen (maybe happending only after an OpenGL app had been run). This happens every some minutes and appears like a short flashing !?
Does anyone else have such an effect?
(Maybe I'll add the log + config when I'm home again...)

snblitz 01-30-04 11:26 PM

Occasional flashes
 
Indeed, I do see occasional flashes. Even saw one while typing this message in probably due to the NVIDIA ad.

stefan42 01-31-04 11:41 AM

Flashing
 
I found some lines in my X11 log that I find suspicious. I'm running XP right now and only have a modem to connect so I don't have the log at hand, but the lines obviously have to do with the modeline entries in the XF86Config (Some numbers with the resolution and geometry information). Right after I start X11 the log looks pretty much like yours, but I noticed that after some minutes those lines with the monitor modelines are added (and maybe after this occasional flickering started). Did you notice something like that in your log?

stefan42 01-31-04 11:58 AM

Thanks to Explore2fs I could get the log: The lines I meant are included in the following part of my log and start with "GetModeLine"

...
(II) XINPUT: Adding extended input device "Mouse[3]" (type: MOUSE)
(II) XINPUT: Adding extended input device "Mouse[1]" (type: MOUSE)
(II) XINPUT: Adding extended input device "NVIDIA Event Handler" (type: Other)
(II) XINPUT: Adding extended input device "NVIDIA Kernel Input Handler" (type: Other)
(II) Mouse[1]: ps2EnableDataReporting: succeeded
(II) Mouse[3]: ps2EnableDataReporting: succeeded
Could not init font path element /usr/X11R6/lib/X11/fonts/local, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/Speedo, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/kwintv, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/truetype, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/CID, removing from list!
SetClientVersion: 0 7
GetModeLine - scrn: 0 clock: 101090
GetModeLine - hdsp: 1440 hbeg: 1456 hend: 1760 httl: 2160
vdsp: 900 vbeg: 900 vend: 908 vttl: 940 flags: 0
GetModeLine - scrn: 0 clock: 101090
GetModeLine - hdsp: 1440 hbeg: 1456 hend: 1760 httl: 2160
vdsp: 900 vbeg: 900 vend: 908 vttl: 940 flags: 0
...
[The GetModeLine are repeated ~ 20 times]

snblitz 01-31-04 06:01 PM

GetModeLine does not occur in my /var/log/XFree86.0.log file, even after severel hours of operation. I do, however, occasionally see the "flicker" sometimes it shows up just after a switch virtual desktops. Other times not at all.

At the office I run with two displays: the laptops LCD, and an external LCD connected to the back. So far as I've noticed, the external display never exhibits the flicker.


All times are GMT -5. The time now is 02:38 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.