nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   panic, my X server crashed ... (system time is not monotonic)! (http://www.nvnews.net/vbulletin/showthread.php?t=23500)

joda 01-13-04 08:13 AM

panic, my X server crashed ... (system time is not monotonic)!
 
Hey!

I'm running kernel 2.4.18-14 ... and nvidia driver NVIDIA-Linux-x86-1.0-5328-pkg1.run ... my X server goes down about every 10/20:th minute, the error is :

(WW) System time is not monotonic

What is that and what can I do about it?

Thanks!

zerohour 01-13-04 03:36 PM

Hey there,

You're suffering from clock drift... Try recompiling your kernel with the
options 'CONFIG_X86_TSC_DISABLE' flag switched on. (Flip the
'Unsynced TSC support' in the cpu section of the configuration options).

Quoting the kernel documention:
" This option is used for getting Linux to run on a NUMA multi-node
boxes, laptops and other systems suffering from unsynced TSCs or
TSC drift, which can cause gettimeofday to return non-monotonic values.
Choosing this option will disable the CONFIG_X86_TSC optimization,
and allows you to then specify "notsc" as a boot option regardless of
which processor you have compiled for."

Try and see if it helps,

zerohour

joda 01-13-04 04:46 PM

thanks!

perhaps this information will make it easier to debug my problem:

I first ran my driver with the correct setup, worked fine, had no problems for 1.5 month.
Then I installed a new monitor, the X server crashed cause of failing to startup with this new monitor, so I pulled down Ctrl-Alt-Backspace to abort, it was trying several time to get X up ... so I aborted it ... I then tried to run the Xconfigurator, no success so I set everything to default, no the X server started. This time a VESA graphic card was default. When installing the new driver from NVIDIA this began to happen ... X Server runs without problem when not using ny opengl application. But when I bring up my 3d app and work in it for like 20 mins it dumps, this often happens when I do certain things like special opengl instructions ...

So is it possible that these problem have something to do with OpenGL or NVIDIA's new driver? Can this cause the Xserver to dump with signal 11 and the "monotonic" time message? Is it possible? And how do I debug OpenGL errors? The XFree86.0.log doesnt show anything more like "monotonic ..." even in verbose mode ...

All help is appreciated, dont know what to do anymore!
Thanks everybody!

// Mike

zerohour 01-13-04 05:26 PM

Well, I'm certainly not qualified to comment on how nvidia's drivers
work internally, but I'm going to take a guess and say that it's probably
using gettimeofday() or some other function which references the system
clock in an important timing loop. Once that's disrupted and it somehow
thinks that time is moving backwards :) , it goes on the fritz and dies.

As far as I know, system clock drift doesn't happen very often on "regular"
systems though... I'm not sure how badly it affects other things, so it may
have been present and you just haven't noticed it until now. For example,
if a network adapter is affected, you might have a packet loss every now and
then, but things (the adapter, the protocol, etc.) are built robust enough so
that the packet is just resent again and you won't notice anything.

Btw, if you see the same thing after recompiling the kernel with that flag,
try using the "notsc" boot option.

joda 01-15-04 03:55 PM

for now I solved it by using a driver from hp , a older nvidia driver, works fine, did some changes to the monitor setting in XFree86 and wola!

think this is a know problem, will talk to HP next time and upgrade my drivers!

thanks!

// m


All times are GMT -5. The time now is 07:27 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.