nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   XFree 4.3 garbles text consoles (http://www.nvnews.net/vbulletin/showthread.php?t=23506)

delt 01-13-04 11:33 AM

XFree 4.3 garbles text consoles
 
I'm not sure if this is a bug in the X server itself, or the nvidia driver, but other users of nvidia cards have reported similar problems.


After starting a X server, my text consoles are completely unusable if i've booted my system with anything other than vanilla 80x25 textmode (ie. with lilo, "vga=something decent")

X starts up and works just fine, but switching to text consoles or exiting X leaves the output on them completely garbled. The screen is snapped to textmode 80x25 (regardless what FB or textmode i try to use) typically with a bunch of random green squares the size of a 80x25 character (those upper ASCII-art characters.....) - or just a blank screen.

The VT's still seem to react normally to keyboard input ie. blind-typing "find /" on a logged-in VT causes some disk access, etc..... If i still have a X server running and return to it, or start a new one, i get a perfectly, normally working X session.




I've tested booting my PC with several console modes, and here's the results:


- Any vesa fb modes: X garbles the console, as described above.

- VGA 80x25 text mode: Only mode that works OK.

- VGA 80x50, 80x43 text modes: X restores the physical mode to 80x25, so i can't
read the bottom half of the screen.

- VGA 132x43, 132x60 text modes: X garbles the console, what's strange is that
the console seems to end up in some low-res graphic mode (320x200??) with
vertical white lines of pixels across all VT's, and random flashing and blinking
squares, each about twice the width * height of a pixel in 320x200.


.... so, it seems i'm stuck with this ridiculous 80x25 console mode until this
bug is fixed.......... :( :( :( :( :(




Machine is a standard i686 PC with a Geforce3 TI, running XFree86 4.3 on Linux kernel 2.4.22. I normally use VESA framebuffer 1024x768x16bpp for console (lilo boot param "vga=791") and the latest drivers from nvidia.com, currently "NVIDIA-Linux-x86-1.0-5328-pkg1.run".


My bug report on xfree86.org 's bugzilla --->

http://bugs.xfree86.org/show_bug.cgi?id=1080




/* EDIT */



> 2) Please attach a copy of your /etc/X11/XF86Config(-4) and
> /var/log/XFree86.0.log files


http://razorback.ca/miscjunk/XF86Config
http://razorback.ca/miscjunk/XFree86.1.log



> 3) Other information that's useful:
>
> - your video card
> - your driver version
> - your distribution
> - your video bios revision (look in /proc/driver/nvidia/cards/0 while X is running)
> - your processor
> - your motherboard model (especially if you're having lockups)
>


- Geforce3 TI 200
- NVIDIA-Linux-x86-1.0-5328-pkg1.run
- Self built, kernel version 2.4.22, XFree86 is from slackware packages
- Video BIOS: 03.20.00.28.00
- Intel Celeron 1.7GHz
- P4S5A/DX+ rev 5.2 with SiS645DX(nb) / SiS962(sb) chipset

delt 01-13-04 01:03 PM

oh - and i should also mention that attempting to use TV-OUT (ntsc-m, composite) also freezes my console. Black screen, no way to restore it other than reboot - although the kernel is still running.

rengels 01-17-04 07:29 PM

garbeled console
 
Hi,
switching of the tv-out seemed to solve the problem for the 4... driver.
Do this with "IgnoreDisplayDevices" "TV". See the readme.

The new 5... driver seemed to solve the problem but it has other funny problems.

delt 01-19-04 10:43 PM

ok, now what if i want to use my tv-out?
i didn't pay an extra $40-50 to nvidia just to have a decorative connector at the back of my PC.

catimimi 01-20-04 10:47 AM

I meet exactly the same problem with kernel 2.4 or 2.6 on SuSE 9.0 and Nvidia driver 5328 :( But TV-out works great. :)

My card is a MSI GeForce4 MX440-TD8X

But I tried Nvidia driver 4363 and fb text consoles works in 800x600 and
TV-out works. :) The problem doesn't seem to come from XFree-4.3 but it looks like a bug in the new release of the Nvidia driver.

Hoping it'll be solved soon.

delt 01-20-04 11:46 AM

alright, thanks.... looks like i'll be using the old driver for now until this bug is fixed.

that is, when (if) i can be bothered to reboot my server again............................

delt 01-22-04 05:54 PM

I just tried to revert to 4496 drivers and it doen't solve the problem, same ****.

LordMorgul 01-22-04 06:18 PM

Uninstall and then try 43.xx or earlier. Try booting without the tv-out cable plugged in and check if this stops the terminal corruption.

LordMorgul 01-22-04 06:27 PM

Re: XFree 4.3 garbles text consoles
 
For reference:
- Any vesa fb modes: successful (vga=791, 792)
- VGA all modes reported by vga=ask: successful.

- Geforce4 TI 4400
- NVIDIA-Linux-x86-1.0-5328-pkg0.run -- patched www.minion.de
- Self built, kernel version 2.6.0, X from Fedora packages (XFree86-4.3.0-42)
- P4 2.0a on Intel i850e at 4xAGP (with FW/SBA)

I haven't had this corruption problem with any X 4.3 using 43.xx and above drivers. I feel its most likely an agp support issue with some card / mobo combinations. Are you guys using agpgart or nvagp?

catimimi 01-26-04 05:32 AM

I tried with both nvagp and agpgart and it is the same result.

But as you I suspect an AGP compatibility problem. As a GeForce 5200 seems to work correctly, I got the opportunity to try one. And at boot I get a black screen :D

My motherboard is an ASUS CUV4XDLS with a VIA Chipset and an AGP Pro Slot told to be backward compatible with AGP4X/2X.

Did some one meet the problem with an ASUS motherboard ?, did you solve it ?, do I have to tune the bios. The AGP strength is set to OxEA.

Thanks for reply.

Michel.

jschellhaass 01-26-04 10:41 AM

I don't know if this will help or not since I haven't seen the problem.


http://www.rastersoft.com/supervesafb_en.html

jeff

delt 01-26-04 05:50 PM

ok this is weird, i've had some hardware issues on this pile of junk and i had to temporarily setup my windowz machine (pIII 700MHz, via VT82??? chipset) as my main box, and with the same video card (geforce3 TI) the 5328 driver seems to work perfectly on the pIII hardware.

weird.................

oh - i had AGP disabled on my P4, and even then everything f????ked up.


All times are GMT -5. The time now is 07:41 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.