nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   RH7.3 & nVidia driver problems (http://www.nvnews.net/vbulletin/showthread.php?t=2357)

BigChin 09-29-02 02:11 PM

RH7.3 & nVidia driver problems
 
Hey all,

Main details:
RedHat Linux 7.3, latest kernel and all updates aquired.
Trying to install Leadtek Ti4200 128MB card, followed the HOWTO here: http://www.nvnews.net/vbulletin/show...=&threadid=648

Used NVchooser.sh to tell me to download: NVIDIA_kernel-1.0-2960.rh73up.athlon.rpm & NVIDIA_GLX-1.0-2960.i386.rpm

Installed those using rpm -ivh <filename>
Tried to use: XFree86 -configure but got the following error message:

"XFree86 has found a valid card configuration.
Unfortunately the appropriate data has not been added to xf86PciInfo.h.
Please forward 'scanpci -v' output to XFree86 support team."


So I ignored that step and went onto modify the XF86Config-4 file as instructed. On completion of that I attempt to startx and got the following message:

"(EE) NVIDIA(0): Failed to initialize the NVdriver kernel module!
(EE) NVIDIA(0): *** Aborting ***
Fatal server error:
no screens found"


So then I run the nv_check.sh script. It runs through fine until the end where it gives me the following:

"The NVdriver kernel module does not seem to be loaded. The 3D drivers will not work without it... Please compile it for your kernel, set it up to insert the module on boot, then run this script again. Remember if you are having trouble compiling the module, try adding -D_LOOSE_KERNEL_NAMES to the Makefile."

Now being a bit of a newbie I am lost as to what that is asking me to do. If somebody could help me with this (step-by-step instructions is possible) then I'd be very appreciative.

Or maybe the error is with the XFree86 -configure, I don't know. Any help would be great! :)

mit 09-30-02 02:00 PM

hmm
 
you and me seem to have the same sort of problem

i am using 7.1 redhat, with a gf4 ti 4200 too

im gonna subscribe to your thread, and if you wanna check mine for a reply, it is

blinking nvidia logo...

good luck

-mit

BigChin 09-30-02 04:44 PM

I fixed that problem. Turned out that the NVIDIA_kernel drivers weren't installing successfully because I didn't have the Linux kernel source code on my machine. Had to install it from the Linux CD's and bang, NVIDIA drivers install fine, it all works nicely. Oh, I ended up using the .tar.gz files.

But now I have another problem. I decided to use up2date and updated the kernel from 2.4.18-3 to 2.4.18-10 as well as the other things it told me to download.

Now of course the "Failed to initialize the NVdriver kernel module!" message is back. So I try to install the NVIDIA_kernel again and get the following message:

"make: *** No rule to make target '/lib/modules/2.4.18-3/build/include/linux/config.h', needed by 'nv.o'. Stop."

So the install doesn't work. Anyone any ideas on how to get round this?

mtrr 09-30-02 04:59 PM

you need a configured kernel source tree to build kernel related
stuff like the nvidia driver, or the intel e100/e1000 nic driver. nvidia
brings enough documentation to get things up and running.

you could come along with just the kernel headers from your distributor,
but I wouldn't bet.

NVLinux 10-01-02 01:33 AM

install the RPM packages that are coded for your kernel. NO NEED FOR THAT NV_CHECK...Install the one RPM package for the kernel first, then the RPM for the X...after you have finished, go in /etc/X11 and edit your XF86Config-4 file with the following :
# out the "dri" and "GLcore" in the LOAD
and replace "nv" with "nvidia" in the DRIVER...and make sure all the screen setting and refresh rate are correctly set in this file also...then issue a startx command...


All times are GMT -5. The time now is 02:44 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.