nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   GeForce 2,porblems.. newer drivers are slower than tthe old one (http://www.nvnews.net/vbulletin/showthread.php?t=23629)

pacaj2am 01-15-04 06:52 PM

GeForce 2,porblems.. newer drivers are slower than tthe old one
 
1 Attachment(s)
Hi, now I'm little bit confused, because of drivers. The drivers i uesed was faster.

Now, runnig glxgears the FPS is 5 :-(

My configuration:
I am running Fedora core 1 with 2.4.22 kernel,
Soltek-KT400C motherboard
AMD 1700+CPU
512 MB RAM

version of drivers - the last one the 5328 one

[root@paci nvidia]# cat version
NVRM version: NVIDIA Linux x86 nvidia.o Kernel Module 1.0-5328 Wed Dec 17 13:54:51 PST 2003
GCC version: gcc version 3.3.2 20031022 (Red Hat Linux 3.3.2-1)

Quote:

here is XF86Config
-------------------------------------------------------------------------
# XFree86 4 configuration

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "cz_qwerty"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "KFC CA15/1505/1506/1507/1515DX"
HorizSync 30.0 - 60.0
VertRefresh 50.0 - 100.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 2 MX (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

[root@paci X11]# cat XF86Config
# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "cz_qwerty"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice" Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "KFC CA15/1505/1506/1507/1515DX"
HorizSync 30.0 - 60.0
VertRefresh 50.0 - 100.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 2 MX (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
-----------------------------------------------------------------------
Could you be so kind and help me?

Thank you PACi

helios 01-15-04 10:56 PM

Hi pacaj2am

The Warning you're getting in your log file - "Could not verify AGP usage", would most likely be caused by a buggy installer from the nVidia site. If you download and use the installer from http://www.sh.nu/download/nvidia/linux-2.4/, it has this AGP problem fixed.

I had the same problem, and this fixed my performance bottleneck.

HTH
helios

pacaj2am 01-16-04 06:00 AM

Quote:

Originally posted by helios
Hi pacaj2am

The Warning you're getting in your log file - "Could not verify AGP usage", would most likely be caused by a buggy installer from the nVidia site. If you download and use the installer from http://www.sh.nu/download/nvidia/linux-2.4/, it has this AGP problem fixed.

I had the same problem, and this fixed my performance bottleneck.

HTH
helios

THNX to HELIOS. It helped much... :-) Now everything works as i was thinking it should.

[flame]
Why there have to be such an unofficial driver, which works... Hey, guys from NVidia, where's the problem?
[/flame]


All times are GMT -5. The time now is 09:29 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.