nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Having a rough time getting ANY drivers to work under Fedora Core (http://www.nvnews.net/vbulletin/showthread.php?t=23630)

Usumbara 01-15-04 08:16 PM

Having a rough time getting ANY drivers to work under Fedora Core
 
First, I'm pretty much a Linux newbie with a Geforce 4 Ti 4200.


But I've tried the newest drivers (the 53.xx) and I've tried the older drivers (Basically any one that had the installer)


I editted my XF86Config as the Readme said.

I don't know if it makes a difference, but the openGL screensavers work flawlessly. (Except on the 5x.xx drivers, everything was still using software rendering when I used those for some reason.)


With all of the 4x.xx drivers, X would reboot every time I tried to run Enemy Territory. The screen would go black (like it was loading) except I could "pan" the screen (The desktop was larger than my resolution.) and eventually X restarts.


So I came across the 46.20 drivers and I've had more luck with those: X doesn't reboot, the game actually *loads* but the screen remains black. Meaning: I can hear the intro video playing, I can hear the music of the main menu (And I can hit ESC to skip the intro.) But I can't SEE anything.


Alt-Enter to window the game makes no difference.


Any ideas?

Usumbara 01-16-04 02:47 PM

Anyone?

blueworm 01-16-04 04:53 PM

post your: XF86Config-4; /var/log/ XFree86.0.log; dmesg
and also start enemy-territory from console and post any errors that you may get.

LordMorgul 01-17-04 05:08 AM

Fedora Core (aka Yarrow) uses /etc/X11/XF86Config as the primary X11 config. Please post that as requested (just not the -4 file), so that we can help you verify the drivers are setup correctly.

Enemy territory runs well for me, however it does suffer the occasional blank screen problem, and some crashes (which incidently DO leave your screen in the wrong resolution as you describe). To correct this when it happens, simply use ctrl-alt-+ to change to the desired resolution again. The blank screen happens infrequently but its not unusual. Deleting or rebuilding the config files for ET should fix that.

Did you install enemy territory before or after you installed the drivers?

ckloiber 01-17-04 11:40 AM

Use CC=gcc32 in Fedora Core 1
 
The kernel in Fedora Core 1 is not compiled with the system's main compiler, to compile the nVidia drivers successfully, you must specify which compiler to use. For instance, the the (current as of this writing) nVidia drivers:

# CC=gcc32 sh NVIDIA-Linux-x86-1.0-5328-pkg1.run

Will compile and install the drivers.


All times are GMT -5. The time now is 08:08 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.