nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   "Failed to load GLX" on Debian with kernel 2.6.1 (http://www.nvnews.net/vbulletin/showthread.php?t=23646)

glyndwr 01-16-04 04:54 AM

"Failed to load GLX" on Debian with kernel 2.6.1
 
OK... this worked up until yesterday! I had 2.6.1 running with a minon.de patched version of the 53XX driver and it was all fine. Had to reboot yesterday for something and boom, suddenly X wouldn't start. If I commented "load glx" out of XF86Config-4 I had "failed to load GLX", if I left it in I had "Initialisng GLX" followed by being dumped back to the console with no other error messages.

Googling around made me suspicious about the TLS libraries, plus the only big change that had happened in the period when it stopped working was an apt-get dist-upgrade, so I followed these instructions to build a proper Debian kernel, based around the 4496 nVidia drivers. This seems to have worked, and this time the TLS libraries have been installed. I have verifed that both the kernel module and GLX libraries are the downgraded version; I initially installed just the kernel module, and starting X threw an error about mismatched driver versions. Installing the nvidia-glx debian package cleared this error, so I imagine the GLX library is now the right version.

Now, when I start X, I get "failed to initialise GLX" regardless of whether "load GLX" is in the XFConfig-4 or not. This is rather frustrating. I don't particularly care about 3d acceleration, I just want it to work, but I'm not even all that sure about how to get more information on what is wrong. I'm about to turn my second monitor off and revert back the open source nv driver instead, but obviously I'd like my TwinView back. Can anyone make any suggestions?

glyndwr 01-16-04 05:08 AM

dmesg output
 
1 Attachment(s)
see attached

glyndwr 01-16-04 05:09 AM

XF86Config-4
 
1 Attachment(s)
see attached

glyndwr 01-16-04 05:10 AM

XF86 log
 
1 Attachment(s)
see attached

glyndwr 01-16-04 05:18 AM

Aha, getting somewhere now, but I still need help
 
1 Attachment(s)
Hmmm, OK, if I try and start X11 with "load GLX" in the config file I get this sort of thing:

[localhost:~/Desktop] rich% grep -i gl XFree86.0.log
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
dlopen: /usr/lib/tls/libGLcore.so.1: undefined symbol: _nv000024gl
(EE) Failed to load /usr/X11R6/lib/modules/extensions/libglx.so
(II) UnloadModule: "glx"
(EE) Failed to load module "glx" (loader failed, 135874339)
(EE) NVIDIA(0): Failed to load GLX
(II) Loading extension NV-GLX

This looks more promising, but I'm still not all that sure what to do about it. Suggestions? Anyone? Please?

glyndwr 01-16-04 02:08 PM

Solved it!
 
Sorted it in the end. Part of it was a mixture of driver versions I had to clear up; part of it was an X11 problem unrelated to nVidia.

Write up of my solution, in case anyone needs it in the future.


All times are GMT -5. The time now is 02:49 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.