nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   App Segfaults with 5328 drivers (http://www.nvnews.net/vbulletin/showthread.php?t=23684)

angelic 01-17-04 05:39 AM

App Segfaults with 5328 drivers
 
I'm a big fan of Glaxium (http://xhosxe.free.fr/glaxium/) even though it doesn't get developed anymore.

Until recently I have been able to run it on Fedora Core 1 by building it using Freeglut (I have built RPMs of Freeglut at http://jumpgate.homelinux.net/random/freeglut-fedora). I also found that I had to apply the libtool fix to libGL.la.

When I updated to the 5328 drivers I found that it would crash on startup with a segfault. gdb showed that it was falling over inside a glCombinerInputNV call in scene.cpp or myship.cpp. Since I'm not a C++ or OpenGL programmer I found it incredibly hard to debug so I'm not sure of the exact problem.

Anyway when I went back to the 4620 beta drivers I was amazed to find that Glaxium worked again. So this points to an issue with the driver package. I wonder whether anyone has any idea what is wrong here?

On a side note, I see that there are a bunch of GL headers in /usr/share/doc/NVIDIA_GLX-1.0/include/GL. Are these intended to replace the ones that come with XFree86 in /usr/share/include/GL? When I try to build with them I get compilation errors.

whig 01-17-04 08:18 AM

Do you have a Via chipset? I do and it doesn't like 5328 drivers. So like you, I use 4620. When you say it won't compile are you trying to compile (link) the nvidia kernel module, the game (I guess) or something else? All those compiles depend on the kernel includes to be present, and in a place where the compiler can find them.

angelic 01-17-04 08:34 AM

I do have a VIA chipset actually, but I have no other problems with the driver itself. X works, glgears gives good benchmarks, other games seem OK (well Q2 worked... didn't get too deeply into any others). I'm running a 2.4.22-2149 kernel from Fedora.

Everything compiles fine. It is just that the game binary segfaults at the function I quoted using the 5328 driver.

The compilation errors I referred to are if I try to use the GL headers provided with the NVIDIA GLX stuff instead of the ones from the XFree86-devel RPM. That was a side issue. I am confused as to what those headers are intended for.


All times are GMT -5. The time now is 07:25 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.