nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   nvidia drivers kernel 2.6.1 .. no modversions (http://www.nvnews.net/vbulletin/showthread.php?t=23719)

sndev 01-18-04 07:04 AM

nvidia drivers kernel 2.6.1 .. no modversions
 
hello all

i have setup the kernel 2.6.1 and when i go install nvidia drivers for my gforce i take the error "no modversions.h in my include files on the kernel" .. what can i do ?

thx for timing

TheOneKEA 01-18-04 07:58 AM

Enable CONFIG_MODVERSIONS and recompile.

sndev 01-18-04 08:34 AM

this is enable ..
from my .config



#
# Loadable module support
#
CONFIG_MODULES=y
CONFIG_MODULE_UNLOAD=y
CONFIG_MODULE_FORCE_UNLOAD=y
CONFIG_OBSOLETE_MODPARM=y
CONFIG_MODVERSIONS=y
CONFIG_KMOD=y

and the modversions.h does not exist :(

volt 01-18-04 09:10 AM

Re: nvidia drivers kernel 2.6.1 .. no modversions
 
Quote:

Originally posted by sndev
hello all

i have setup the kernel 2.6.1 and when i go install nvidia drivers for my gforce i take the error "no modversions.h in my include files on the kernel" .. what can i do ?

thx for timing

Here are 2.6 ready NV drivers :)

http://www.sh.nu/download/nvidia/linux-2.6/

If not, try this:

1. Shut down your X and do

2. CC="gcc32" sh <NV driver.run> --add-this-kernel
(this will create the package based on your kernel). Now do

3. CC="gcc32" sh <NV driver-custom.run>
(it should install the driver, but I'm not 100% sure it will heh)

sndev 01-20-04 03:08 PM

it's working but this happens only if i run lsmod ./nvidia.o
my kernel does not loading this modules ..... from lsmod

Module Size Used by
nls_iso8859_1 4416 1


what can i do for this? what should enable? i want load this module because does not startx :(


All times are GMT -5. The time now is 06:18 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.