nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA FreeBSD (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47)
-   -   FreeBSD glx problem (http://www.nvnews.net/vbulletin/showthread.php?t=23768)

samu 01-19-04 04:03 PM

FreeBSD glx problem
 
I'm having this strange problem in loading the "glx" XFree extension:

(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
dlopen: /usr/X11r6/lib/modules/extensions/libglx.so: Undefined symbol "__nvsym15122"
(EE) Failed to load /usr/X11R6/lib/modules/extensions/libglx.so
(II) UnloadModule: "glx"
(EE) Failed to load module "glx" (loader failed, 7)

X starts up fine with the nVidia splash screen and works just fine. GLX-applications (such as glxgears) do not work. Is this a driver issue or have I just done something wrong?

Driver version: 1.0-4365 (from ports collection, installed without errors)
XFree version: 4.3.0
Freebsd: 5.1-release
Card: Geforce2 MX 32MB

LinuxHatesMe 03-08-04 04:03 PM

*bump*

I have a similar issue. I don't get the error on loading up X but I have the glxgears issue. Not a huge problem in terms of so far it hasn't stopped me from doing anything I needed, but it seems to be a good indicator that things aren't completely installed correctly. I have FBSD 4.9 Release installed and used ports to installed the 4365 drivers. Everything thus far has seemed to install and function properly aside from glxears and a library issue trying to run RTCW: ET.


All times are GMT -5. The time now is 05:04 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.