nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Riva TNT2 Model 64 Issues (http://www.nvnews.net/vbulletin/showthread.php?t=23791)

Timmeah! 01-19-04 09:36 PM

Riva TNT2 Model 64 Issues
 
1 Attachment(s)
I've previously troubleshooted my personal Debian Sid box with NVIDIA GeForce4, but I can't get the NVIDIA drivers to work on this older machine!

The early packages (from 4363 and earlier) don't build due to a sanity-check bail. I have custom built this kernel with the current Debian Unstable release (GCC 3.3.3). Versions 4496 and onward build ok, but X can't start.

For the more recent 5328 installer (and ideally more bug-free!), I get the following log file that I've included. ALT-F1ing back to the first console shows an error message that the X session was terminated, but no decent errors.

I have tried the following (previously):
- using the minion.de patches and patched versions to manually build
- changing the SDRAM/SGRAM variable in the os_registry.c file (from FAQ)

The "nv" driver works ok, but I'd really love the NVIDIA drivers to build - as this machine is wanted for a Multimedia box (and hence the Xv enabled NVIDIA driver would be ok... I currently only have the X11 overlay working).

Could this also be a VIA chipset issue? My own personal machine is still using the 4363, coz they work perfectly and don't crud my VIAKT333. At the same time, I'd hoped the 4363 would work on this machine, which is also VIAed.

Have I missed an important Kernel support module? I'm cool to rebuild if you can suggest anything.

Cheers

Tim
-------

System info: Debian Sid, GCC 3.3.3, Kernel 2.4.22 (custom), Riva TNT2 Model 64

cbeever@newbeast:~$ lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT82C693A/694x [Apollo PRO133x] (rev c4)
00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro133x AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 22)
00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT8233/A/C/VT8235 PIPC Bus Master IDE (rev 10)
00:07.2 USB Controller: VIA Technologies, Inc. USB (rev 10)
00:07.3 USB Controller: VIA Technologies, Inc. USB (rev 10)
00:07.4 SMBus: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 30)
00:07.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97 Audio Controller (rev 20)
00:0b.0 Communication controller: Conexant HSF 56k Data/Fax Modem (WorldW SmartDAA) (rev 01)
00:0d.0 Ethernet controller: Accton Technology Corporation SMC2-1211TX (rev 10)
01:00.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro] (rev 15)

cbeever@newbeast:~$ cat /proc/mtrr
reg00: base=0x00000000 ( 0MB), size= 256MB: write-back, count=1
reg01: base=0x10000000 ( 256MB), size= 64MB: write-back, count=1
reg02: base=0xda000000 (3488MB), size= 32MB: write-combining, count=1
reg06: base=0xe0000000 (3584MB), size= 32MB: write-combining, count=1

Timmeah! 01-19-04 10:57 PM

Having had some follow up from Andy, I've now also attempted the following with the 5328 series driver:
- Using "noapic" as kernel boot parameter
- Recompiling kernel with AGP support as module, to possibly allow for NVAGP to take over (chipset is apparently supported).

... both have provided no success (same errors). More help, pleeeease!

Cheers

Tim


All times are GMT -5. The time now is 01:08 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.