nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   redhat linux 9 first boot hang with no video output (http://www.nvnews.net/vbulletin/showthread.php?t=23869)

qiw 01-21-04 05:16 PM

redhat linux 9 first boot hang with no video output
 
I am very new to Linux, please bear with my silliness...

I installed redhat linux 9 in a Dell OptiPlex GX270 desktop. The computer has a dell 1703FP monitor and a nVidia GeForce FX5200 video card. Windows 2000 was installed in the primary master drive. Linux was installed in the primary slavery drive (default workstation installation with several custom selected packages). During installation the graphical installation software failed and the installation was performed in text mode but went through ok.

When the machine was reboot after installation, after "start firstboot" was displayed, the screen went black and the machine hang without video output. I tried "ctrl-alt-f1" and "ctrl-alt-f2" but nothing happened.

During installation, the X-configuration was done as the following:
video card was probed as generic vesa, I changed it to generic nVidia GeForce FX, the RAM was set as detected,
monitor was probed as 1703FP with Sync ranges as 30-80 and 56-76,
color depth was set as true color and the resolution was set as 1024*768.

right now lilo works fine and from there I can boot into windows; no matter boot from the floppy boot disk or from hard disk using lilo, the machine hangs after displaying the line"start firstboot".

I would appreciate your input very much...

LordMorgul 01-22-04 03:06 AM

You must use 'nv' rather than 'vesa'
 
The generic FX card setup in Redhat 9 will use the 'vesa' X driver, one that is not well supported for the FX chipset. The necessary fix is to switch the used driver to the 'nv' driver instead. You have several options for doing this, but the two simplest are:

Reinstall Redhat, but choose 'Geforce 2 generic" instead of FX generic. This should use the 'nv' driver instead of the 'vesa' driver. Do this if you have difficulty trying the better option below.

You need to first boot the machine into single user mode or use the redhat cd to enter rescue mode. Use 'linux rescue' at the first prompt on the cd, or to boot to single user mode, you need to add an option to the kernel line of the lilo config, I don't use lilo so I'm not much help with this. The option you would need to add is: init 1

Once you have a terminal prompt, either by rescue mode or single user mode, you need to edit a config file, you can do this with one of several terminal text editors (joe, pico, vi, emacs). If you need to, search google for a short tutorial on one of them.

Edit the file: /etc/X11/XF86Config
Find the line that reads: Driver "vesa"
Change it to read: Driver "nv"
Save the file.

You can now reboot and use X.

Fedora Core 1 should handle the video card correctly from the beginning. I suggest you consider using Fedora, since Redhat 9 is a discontinued product of Redhat, which will not have continued security patch releases.

qiw 01-22-04 01:51 PM

thank you, but it still hangs
 
Hi, thank you for your suggestions. I reinstalled Linux and set the driver as geforce 2 generic (custom installation with everything, and I set graphic mode as the default mode). This did not help the situation, though :-( it still hangs after "start firstboot" was displayed. I really want to make it work. Do you have any other suggestions. Maybe after several tries I will install Fedora instead. Thanks a lot ...

LordMorgul 01-22-04 02:51 PM

I'm sorry the suggestion didn't work. If you use the linux rescue mode to make the change to the config file however, I'm pretty sure you'll be up and running. Using Fedora is better, but you can upgrade to it at any time from RH9 as well.

Editing config files by hand will become very important to you, and is not as daunting as it might sound at first.

Here's one tutorial that could help you get started.
http://www.eng.hawaii.edu/Tutor/vi.html

If you do use linux rescue mode on the cd, you'll be prompted to enter a command to 'chroot' into the linux install on your harddisk. You should do this command. Then edit the file.

qiw 01-23-04 08:55 AM

thank you!
 
Hi, thanks a lot. You are right. I used linux rescue mode and modified the configuration file as you suggested, then it works all fine now. It is strange that during the second installation, I set the driver to geforce 2 generic, but in the configuration file, it was still vesa. Anyway, thanks again!

LordMorgul 01-23-04 03:07 PM

Yes, when I configured an FX5200 at my LUG's Linux install party (I have a ti4400) the generic gef2 selection worked fine, but it was the long shot chance. Glad you've got the problem fixed now, that issue confused me when I first saw it as well.


All times are GMT -5. The time now is 08:02 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.