nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Nvidia nforce drivers - unresolved symbols? (http://www.nvnews.net/vbulletin/showthread.php?t=23910)

baldy 01-22-04 11:46 AM

Nvidia nforce drivers - unresolved symbols?
 
I have downloaded and installed the nvidia nforce drivers for sus8.1
I have an nforce2 mobo.

the nvnet driver works a treat. The usb driver appears to work. The audio driver fails. When I do an insmod nvaudio the following happens -

linux:/home/everyone # insmod nvaudio
Using /lib/modules/2.4.19-4GB/kernel/drivers/sound/nvaudio.o
/lib/modules/2.4.19-4GB/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_probe_codec
/lib/modules/2.4.19-4GB/kernel/drivers/sound/nvaudio.o: unresolved symbol unregister_sound_dsp
/lib/modules/2.4.19-4GB/kernel/drivers/sound/nvaudio.o: unresolved symbol register_sound_dsp
/lib/modules/2.4.19-4GB/kernel/drivers/sound/nvaudio.o: unresolved symbol register_sound_mixer
/lib/modules/2.4.19-4GB/kernel/drivers/sound/nvaudio.o: unresolved symbol unregister_sound_mixer
/lib/modules/2.4.19-4GB/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_set_dac_rate
/lib/modules/2.4.19-4GB/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_set_adc_rate
linux:/home/everyone #

Now I looked at the docs and they said "your running kernel does not match your kernel sources". So I compiled a new kernel with the sources that came with the distro, just to make sure and the problem is exactly the same. I have also tried an older version of the same drivers with exactly the same results.

Can anyone suggest where I go from here?

Cheers

Pete

tuxpandu 01-24-04 12:35 AM

nvaudio.o driver have dependency with ac97_codec. So before you insmod it, try to load ac97_codec first:

# modprobe ac97_codec

# lsmod
Module Size Used by Not tainted
ac97_codec 13428 0

then insmod nvaudio:

# insmod /lib/modules/{your_kernel_version}/kernel/drivers/sound/nvaudio.o

and you should see something like these using dmesg:

# dmesg

... cut

Nvidia + AC97 Audio, version 0.24, 12:47:29 Jan 23 2004
Nvaudio: in Funcction Nvaudio_init_module
PCI: Setting latency timer of device 00:06.0 to 64
Nvaudio: NVIDIA nForce2 Audio found at IO 0xd400 and 0xd000, IRQ 11
Nvaudio: Audio Controller supports 6 channels.
NVaudio: Defaulting to base 2 channel mode.
ac97_codec: AC97 Audio codec, id: ALG32 (ALC650)
Nvaudio: only 48Khz playback available.
Nvaudio: AC'97 codec 0, DAC map configured, total channels = 6

:cool:


All times are GMT -5. The time now is 07:35 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.