nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   SATA question (http://www.nvnews.net/vbulletin/showthread.php?t=23993)

darkshadow 01-24-04 01:31 PM

SATA question
 
I hope this is a good board for this but I know there are users of this mobo here.

I think I remember a remark along time ago that the SATA support on a "ASUS A7N8X-Deluxe" had problems is this true?

I want to add a Seagate 120gb sata drive to my computer for use as a dedicated video tv capture drive (720x480 uncompressed)

I am using the 2.6.0 Linux kernel (Distro is Linux From Scratch) which I heard has SATA support but don't know if it is only for certain sata controllers so need to know if anyone has got this setup to work

Moled 01-24-04 01:48 PM

according to:

http://www.asus.com/prog/spec.asp?m=A7N8X%20Deluxe

you have: Silicon Image® Sil 3112A Controller with 2 ports

which is the same as what im using

lspci:
03:0b.0 RAID bus controller: CMD Technology Inc Silicon Image SiI 3112 SATARaid Controller (rev 02)


it works fine

dmesg:
SiI3112 Serial ATA: IDE controller at PCI slot 0000:03:0b.0
SiI3112 Serial ATA: chipset revision 2
SiI3112 Serial ATA: 100% native mode on irq 19
ide2: MMIO-DMA at 0xf9812000-0xf9812007, BIOS settings: hde:pio, hdf:pio
ide3: MMIO-DMA at 0xf9812008-0xf981200f, BIOS settings: hdg:pio, hdh:pio

oh make sure you use 2.6.1 at least
security issue with 2.6.0 and before

TheOneKEA 01-24-04 02:29 PM

Right - the latest versions of Jeff Garzik's libata driver fully support the Sil3112A controller circuitry; you can download newer versions of it from his website, IIRC.

darkshadow 01-25-04 07:28 PM

Final questions.

I heard SATA is hot swappable does that mean I don't have to reboot when I get the physical drive. And how do I tell Linux I added it.



Is this all I need to change in the kernel to add support

in device drivers "SCSI device support"

In "SCSI device support"/"SCSI low-level drivers"
"Serial ATA (SATA) support" + "Silicon Image SATA support"

Moled 01-26-04 05:47 PM

they do support it, but the drivers do have to as well, which afaik none do atm :(

darkshadow 01-28-04 01:53 PM

Thanks for the info.

darkshadow 02-04-04 12:19 AM

Ok I got the drive now and it is installed, but I can't figure out what device it is in /dev I have already tried all the /dev/hd? and /dev/sd?

dmesg gives this output and yes I know I accidently put it on the second connection

###################################
libata version 0.81 loaded.
ata_sil version 0.51
ata1: SATA max UDMA/133 cmd 0xF9845080 ctl 0xF984508A bmdma 0xF9845000 irq 11
ata2: SATA max UDMA/133 cmd 0xF98450C0 ctl 0xF98450CA bmdma 0xF9845008 irq 11
ata1: no device found (phy stat 00000000)
ata1: thread exiting
scsi0 : ata_sil
ata2: dev 0 cfg 49:2f00 82:346b 83:7d01 84:4003 85:3469 86:3c01 87:4003 88:207f
ata2: dev 0 ATA, max UDMA/133, 312581808 sectors (lba48)
ata2(0): applying pessimistic Seagate errata fix
ata2: dev 0 configured for UDMA/133
scsi1 : ata_sil
Vendor: ATA Model: ST3160023AS Rev: 0.81
Type: Direct-Access ANSI SCSI revision: 05

TheOneKEA 02-04-04 06:10 AM

Weird.

Did you compile SCSI disk support into this kernel? If you didn't, make sure the sd_mod module is loaded.

darkshadow 02-04-04 10:45 AM

Thanks, I did miss the scsi disk support. Once I added that it worked perfectly (perfect timing for a recompile since kernel 2.6.2 just got released) and I even remembered to plug the cable into the right connection on the mobo. I found it on /dev/sda and it worked like a dream

jedah 02-11-04 03:50 AM

I have a question:

Does Linux have support for serial ATA hard drives??If I want to make the hard drive work on SUSE 8.0, an MSI FISR2 motherboard and a HD Maxtor 120GB SATA what should I do??Do I have to install a 2.6 kernel???


All times are GMT -5. The time now is 06:02 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.