nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   driver install problems on RedHad WS 3 -- resolved (http://www.nvnews.net/vbulletin/showthread.php?t=24000)

davetheguru 01-24-04 05:13 PM

driver install problems on RedHad WS 3 -- resolved
 
I'm new to this forum. Built up a new PC last month with Red Hat WS 3 (kernel 2.4.21-9.EL) using the nVIDIA GeForce4 MX440-T8X video card. I downloaded the NVIDIA-Linux-x86-1.0-5328-pkg1.run up-to-date driver and installed it per the README file (sh'd it and edited XF86Config per instructions). Everything was fine until I tried to get X up. The RedHat graphical greeter would hang at login with only the cursor movable. Even in runlevel 3 using startx would give me a blank screen and just the cursor.
I read thru the README file and checked all the tips that seemed applicable and all looked OK (symlinks were OK, etc.). But then I was looking at the XFree86 log and noticed at the end that AGPGART was the mode being started on it. So as the last thing to try, from looking at the XF86Config Options section of the README file, I added the line:
Option "NvAGP" "1"
in the "nvidia" Device section to force using NVIDIA internal AGP support.
Guess what? The driver works now.
I'm just passing this along in case someone else is having problems -- really look at that README file.
BTW, can anyone tell me wat AGPGART is? (what does GART stand for?) I couldn't find explaination on this site and I can't seem to connect to www.agpforum.org to check there.

whig 01-24-04 06:39 PM

Graphics Address Remapping Table


All times are GMT -5. The time now is 11:43 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.