nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   5328 Driver and SuSE 9.0 (http://www.nvnews.net/vbulletin/showthread.php?t=24009)

rvoll 01-24-04 09:57 PM

5328 Driver and SuSE 9.0
 
I installed SuSE 9.0 and did the normal upgrade through their Yast program. The original installation was kernel version 144. The Yast upgraded the kernel to 166. When I extracted your run file, you only had the pre-compiled version for 144. When the installer tried to recompile, it had the wrong directory structure for SuSE and thus could not access the header files. I tried to force the 144 kernel with the --kernel-name argument, and of course, that didn't work either. Do you have a workaround? Can you give me a list of files to put in the directory you expect to find them in? I can't find a way to go back to the 144 version without a complete reinstall which takes hours over the web.

whig 01-24-04 10:12 PM

Can you roll your own kernel? It's a skill worth learning.

rvoll 01-24-04 10:21 PM

Mr
 
I am a very experienced Windows user and just started with Linux. I certainly don't know how to compile my own kernel.

SuLinUX 01-24-04 10:58 PM

Are you sure you've got the kernel-source installed?, because that should'nt happen.

rvoll 01-24-04 11:11 PM

Yes, the kernel-source is installed. The header files requested are there, but in different directories than the installer expected. They are in the "linux-include" tree rather than the "linux" tree as the installer desires. That said, they are source files for the 144 kernel and not the 166 kernel... so there are two problems. However, I couldn't even get that far because of the directory mishaps. Not having installed the NVidia driver before, what happen if I reinstall the 144 version from scratch, then install the driver, and then upgrade the kernel? I assume that will also cause dependency problems?

whig 01-25-04 01:20 AM

Try the --kernel-include-path=[KERNEL INCLUDE PATH] option. I've had to do this a few times.

rvoll 01-25-04 09:13 AM

Mr
 
Thanks... But I've already tried to force the kernel-path and, while it gets further, it does not work...

levenger 01-27-04 11:40 AM

you should be able to update the kernel-sources to 166 through online update. I was able to, I'm running SuSE 9.0 Pro

rvoll 01-27-04 12:01 PM

Mr
 
Yes, it finally showed up on YaST and that fixed the problem. I now have the driver installed. Thanks... Now to try and configure Twinview....

Andy Mecham 01-27-04 12:31 PM

Something you should keep in mind: when you update your kernel/kernel sources, you'll need to reboot to actually start using your updated kernel.

--andy

rvoll 01-27-04 02:13 PM

Andy... I already had the new kernel loaded, just not the kernel-sources. SuSE did not give me both at once -- there was a lag. That's what caused the problems.

I've now enabled TwinView. I have a 5200 card w/128MB and I can't seem to get 1600x1200 on both monitors. The highest it will go is 1280x1024. With my Windows Driver, I get 1920x1440 on one and 1600x1200 on the other. I've tried to set up individual monitor settings, but it doesn't work yet. I have to try and figure out my BusID. I think it's 1:0:0 but I'm not sure. I've spent enough time on this today, I have to get back to real work. If I can't figure it out myself, I'll post my XF86Config for comments. Right now, only my main monitor lights up and I did leave out the BusID since it was not in the original file.... I hope that fixes it...

Andy Mecham 01-27-04 02:35 PM

You only really need a BusID entry if you have more than one video card.

I'd suggest posting both your XF86Config and a verbose X log file (startx -- -logverbose 5) here for review.

--andy


All times are GMT -5. The time now is 07:04 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.