nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Screen corruption, crashes, no NVIDIA-GLX (http://www.nvnews.net/vbulletin/showthread.php?t=24014)

ecoffey 01-24-04 11:12 PM

Screen corruption, crashes, no NVIDIA-GLX
 
Hi, I'm trying to get X up and running on my Debian system to no avail.

The symptoms are as follows:

On startup short black horizontal lines are displayed across the top of the stippled b&w X background, then there is corruption all over the screen as the Gnome splash screen displays the Gnome initialization process.
Random junk sometimes appears alongside new windows and other on-screen changes.
xdpyinfo shows GLX, NV-CONTROL and NV-GLX but no NVIDIA-GLX
glxgears runs and crashes the computer (niether CTRL-ALT-DEL nor CTRL-ALT-BKSP work), or prints "Invalid instruction" and exits, or prints "Sefmentation fault" and exits.
X crashes sometimes when opening an application or simply clicking a link or button in Mozilla, or for no apparent reason at all.
"NvAgp" "0" prevents X from loading at all. Other options have no effect.
No serious looking errors/warnings in X log.

The setup is as follows:

Soltek 75MRN-L motherboard, AMD Athlon XP 2600, onboard GeForce4 MX (Video BIOS 04.1f.00.08.00), 512MB ram (32 for video), nForce2 chipset.
Newly installed Debian system with kernel package 2.4.24-1-k7 and XFree86 4.2.1.1.
Installed nForce drivers from NVIDIA_nforce-1.0-0261.tar.gz tarball - all went smoothly.
NVIDIA-Linux-x86-1.0-5328-pkg1.run produces no warnings
All files and symlinks in place
glxgears linking against tls libraries

I have looked long and hard bat cannot find any reports of symptoms matching these, let alone a solution - does anyone here have any idea what might be wrong?

whig 01-25-04 01:12 AM

Do any of the XFree provided drivers (vesa, nv) go? Either will give you a starting point - run xf86config

ecoffey 01-25-04 04:25 PM

nv gives less screen corruption, but crashes soon after launching. VESA, in glorious 8-bit color, works just fine.

ecoffey 01-27-04 02:49 PM

1 Attachment(s)
Has anyone even seen this kind of behavior before? I have attached a log from X for your viewing pleasure.

Andy Mecham 01-27-04 03:12 PM

As a sanity check - are you sure your system RAM is good? Corruption with the nv driver worries me. You can run memtest86 to check your ram.

--andy

ecoffey 01-27-04 03:19 PM

Just downloaded the 5336 drivers - no change.
glxgears came up with an interesing new message the first time I ran it:

glxgears: relocation error: glxgears: symbol gettimeofday, version GLIBC_2.0 not defined in file libc.so.6 with link time reference

It crashed the box te next time.

I'll run memtest86 today and see what it reckons about my RAM.

Andy Mecham 01-27-04 03:25 PM

It sounds like something fundamental is wrong with your install, or something has become corrupted beyond use. :(

--andy

ecoffey 01-27-04 04:38 PM

1 Attachment(s)
This is my second fresh install on this machine, the previous install also suffered this problem. The machine has been tested with Windows and works perfectly. I ran a single pass of memtest86 and it found no problems. I have removed all PCI cards from the machine, underclocked it, turned off as many features that might increase instability as I could find and there is no change. The error and repeted segfaults from glxgears seem like some kind of library/binary-interface/compiler incompatibility.

I've attached my current XF86Config-4 in case I'm missing something obvious.

ecoffey 01-28-04 04:24 PM

I'm running out of things to try. I assume other people have got the driver running without screen corruption and crashes, and with the NVIDIA-GLX extension loaded using an onboard GeForce4 MX, nForce2 chipset, Athlon XP CPU and the latest Debian-unstable/testing yes?

Another thought - the screen the GeForce puts up just after power-on says "Engineering Release - Not For Production Use" - should that worry me?

Andy Mecham 01-28-04 04:27 PM

Quote:

Another thought - the screen the GeForce puts up just after power-on says "Engineering Release - Not For Production Use" - should that worry me?
Yes - where did you get the card? Did you buy it at retail?

--andy

ecoffey 01-29-04 01:10 AM

I bought the system retail from a small supplier in Adelaide (I'll send you his contact details by email).

Soltek's website for the SL-75MRN-L motherboard makes no mention of the issue:
http://www.soltek.com.tw/soltek/prod...N%2FSL-75MRN-L

But it seems some others have had similar problems (see response by poster Philippe L):
http://www.pc97.com/forums/index.php...1&overclockid=

ecoffey 01-30-04 09:45 PM

So what do I do next - This problem renders the computer essentially unusable, so I'd really like to get a replacement board as soon as possible, should I be looking to my supplier, Soltek or nVidia?


All times are GMT -5. The time now is 05:55 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.