nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   X hang after modifying XF86config-4 (http://www.nvnews.net/vbulletin/showthread.php?t=24028)

pprett 01-25-04 10:11 AM

X hang after modifying XF86config-4
 
1 Attachment(s)
hi, after nvidia driver installation (and modifying XF86config-4) i get a black screen. (total hang)

when I change the device driver back to nv, X starts without any problems. I have tried NvAgp 0 (and 1) and pci=noacpi -> but i'm still not able to start X.

when I use nvidia as driver XFree86.0.log contains no information. I don't know what to do. I have this problem with kernel 2.4.18 and 2.6.0. the nvidia card doesn't share it's irq number with any other device (or at least I think so)

System:

AXP 1800
Debian woody (unstable)
256 mb RAM
Mainboard: elitegroup k7s5a (maybe this is the problem?)
nvidia driver version: 5328

Model: GeForce3 Ti 200
IRQ: 5
Video BIOS: ??.??.??.??.??
Card Type: AGP

thx

whig 01-25-04 05:57 PM

In your XF86Config don't load the dri module.

pprett 01-26-04 02:09 AM

dri module is loaded
 
Section "Module"
Load "dbe"
Load "dri" <----
Load "extmod"
Load "glx"
Load "pex5"
Load "record"
Load "xie"
EndSection

whig 01-26-04 06:27 PM

The nvidia instructions say not to load the dri module.

Quote /usr/share/doc/NVIDIA_GLX-1.0/README

In the Module section, make sure you have:

Load "glx"

You should also remove the following lines:

Load "dri"
Load "GLcore"

pprett 01-27-04 01:45 PM

correction
 
hi, thanks for your reply -> I unloaded the dri module but nothing changed

Andy Mecham 01-27-04 02:45 PM

Please post an X log.

pprett 01-27-04 04:31 PM

the problem is - there is no X log. when i start the x server with the nvidia driver no xfree86.0.log is created. when i start with the nv driver everything works all right.

i tried apm=off acpi=off vga=normal -> but no effects.
I run 2 os on my system (Suse 8.1 kernel 2.4.16 nvidia driver 3xxx)
(Debian woody 2.6.0 nvidia driver 4496)

In suse the nvidia driver works - but not on woody

maybe this is a problem with the agp device?

I loaded the module agpgart is this ok? i also set nvagp to 0 -> in order to turn agp support off.

Andy Mecham 01-27-04 06:28 PM

Have you tried with 1.0-5336 on your 2.6 system?

--andy


All times are GMT -5. The time now is 10:24 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.