nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA FreeBSD (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47)
-   -   FreeBSD 4365 driver will not initialize (http://www.nvnews.net/vbulletin/showthread.php?t=24049)

OU812 01-25-04 09:25 PM

FreeBSD 4365 driver will not initialize
 
1 Attachment(s)
I have a personal panic going on here with a machine that I need to get into service and it will not start x.

The HW is a P4 3.0Gz/800FSB/HT in an Abit Ic7 mobo with 1G of memory.

It is a fresh install of FreeBSD RELEASE on the 4 branch (4.9 is the new one) and I configured the kernel per the directions in the driver. It compiled and installed clean. I have tried the startx with and without the AGP option in the kernel and I have tried it with and without the vesa option since I read someplace that might make a difference. I do not know if I have tried every combination of both.

The driver version is NVIDIA-FreeBSD-x86-1.0-4365.tar.gz and it downloaded, compiled and installed clean.

dmesg reports linux.ko and nvidia.ko are preloaded elf modules.

The bottom line is that it seems to do everything right right up to the point where it loads the screen section and then I get:

(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!

It then aborts, unloads the modules (nvidia, vgahw and libvgahw.a) and then gives me:

(EE) Screen(s) found, but none have a usable configuration.

I have attached the XFree86.0.log (I ran it -verbose) and the XF86Config that I used is the sample one with modifications. I removed everything but the single AGP card configurations and modified the horiz and vert rates. I can post it if you want it.

If you have solved this problem or can help me do so... i'm beggin here.

Thanks all.

OU812 01-25-04 09:33 PM

1 Attachment(s)
Well, since I forgot to tell you that the card was an Nvidia FX 5200 and that might be important (:o) I thought I would also post the XF86Config that I used that created the log I just posted.

Sorry about the double posting. At least you get both attachments this way. If there is ANYTHING that I can do or post that you may need please do not hesitate to ask. Well, almost anything. ;)

OU812 01-30-04 03:30 PM

I give up
 
As much as I REALLY like nVidia cards, I was forced to give up. This thread keeps getting views and people seem to want to know what the deal is with FreeBSD and the FX 5200 card - yet no one seems to be able to help.

It APPEARS from my research that the problem has occured in the Linux version of the drivers but the fix has never been ported over to the FreeBSD driver set. I have no idea if this is true and no feedback has ever been sent to me to so I can not be certain of this.

In any case - time forced me to abandon this card. FYI, all you FreeBSD users that feel abandoned, I installed an ATI Xtacy 9600 128MB AGP card with a Radeon 9600 VPU which has all of the same connectors as the FX 5200 in the back and FreeBSD recognized it perfectly with the ati driver that comes in the distro and it works wonderfully.

If nVidia ever gets their drivers working for FreeBSD I hope they supply them to FreeBSD for such an effortless install so I can keep using their wonderful cards. Untill then....

sa- 02-07-04 07:47 AM

oh no... i have bought the same card 2 days ago and been trying to make it work
all the time, having the same problem.
hell, i guess i should go for ati too :rolleyes:

:confused:

zander 02-07-04 12:10 PM

For what it's worth: assuming that the NVIDIA character nodes in /dev exist, the kernel module should produce additional error messages when low-level initialization fails.


All times are GMT -5. The time now is 09:37 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.