nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   no GLUT_ALPHA on 16bpp? (http://www.nvnews.net/vbulletin/showthread.php?t=24142)

sergey akifiev 01-27-04 09:56 PM

no GLUT_ALPHA on 16bpp?
 
have tested on gf256 and gf4 cards with different drivers installed.
all GLUT programs prints out
Code:

sergey@sergey:~/work/opengl$ ./lesson11
GLUT: Fatal Error in lesson11: visual with necessary capabilities not found.

but if i delete `| GLUT_ALPHA' from glutInitDisplayMode() parameters, it works just fine.
glxinfo says:
Code:

... skip ...
  visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x21 16 tc  0 16  0 r  y  .  5  6  5  0  0 16  0 16 16 16 16  0 0 None
0x22 16 dc  0 16  0 r  y  .  5  6  5  0  0 16  0 16 16 16 16  0 0 None
0x23 16 tc  0 16  0 r  .  .  5  6  5  0  0 16  0 16 16 16 16  0 0 None
0x24 16 tc  0 16  0 r  y  .  5  6  5  0  0  0  0 16 16 16 16  0 0 None
0x25 16 tc  0 16  0 r  .  .  5  6  5  0  0  0  0 16 16 16 16  0 0 None
0x26 16 dc  0 16  0 r  .  .  5  6  5  0  0 16  0 16 16 16 16  0 0 None
0x27 16 dc  0 16  0 r  y  .  5  6  5  0  0  0  0 16 16 16 16  0 0 None
0x28 16 dc  0 16  0 r  .  .  5  6  5  0  0  0  0 16 16 16 16  0 0 None

is that known bug or "feature"?
may be something wrong with some settings?

Andy Mecham 01-28-04 12:47 PM

It's correct behavior.

--andy

sergey akifiev 01-30-04 01:00 AM

can u explain, why? or, better, give a link to read to.
thanks in advance


All times are GMT -5. The time now is 08:01 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.