nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Debian and OpenGL (http://www.nvnews.net/vbulletin/showthread.php?t=24146)

docGonzo2000 01-27-04 11:46 PM

Debian and OpenGL
 
I'd been running Libranet GNU/Linux for a while, which is Debian based. After I updated one time, I couldn't get Unreal Tournament 2003 working -- it said that it could not find the OpenGL library, and quit. I have a GeForce FX 5600 with 256 MB DDR running on an Athlon XP.

So, I reinstalled Debian, this time by upgrading to sarge from woody. Finished recompiling the kernel and installed the latest nvidia drivers. (1.0.5336)

Still the same problem. My XF86Config file should be fine. Have glx loading but not GLCore and dri. I checked all of the libraries and symlinks and they look fine. However, xdpyinfo does not list NVIDIA-GLX. It does list NV-GLX, though. I can get some other games to run, like tuxracer. I also reinstalled UT2003 to no avail. Tried winex as well, and it crashes on loading any of the games I had installed.

glxgears loads /usr/lib/tls/libGL.so.1 and /usr/lib/tls/libGLcore.so.1. I'm running the 2.4.23 kernel, by the way.

I've reinstalled so many times over the past few days, ironing out various bugs and trying different distros (mostly different Debian based ones), had problems with compiling the kernel on this iso I got with the beta version of debian-installer on it. Got kernel panics saying it couldn't find the root partition, which grub had just found, on reboot with the new kernel. Same kernel source as I just successfully compiled under the sarge upgraded stable installation.

I hope somebody has some insight on this problem. I don't really want to have to switch to a different distro. I like apt-get too much.

markupstart 01-28-04 12:34 AM

Recently I had a problem with /usr/X11R6/lib/modules/nvdia-driver. It has the wrong version of libglx. Once I replaced it with the version found in /usr/X11R6/lib/modules/extensions, it restored my 3d, where winex and everything works fine now. The wrong file was 667.1 kb, the right file was 675.6. There were two files. libglx.so.1.0.4496 and a symlink to the file called libglx.so. Check it out to make sure you have the same version of the file in both dirctories. A clue I had was I check out my XFree log, and it gave me an error on loading glx in the particular directory, so I knew something was up. Try this, or check out your log file and see what it says in reference to loading glx. Maybe someone can help you.

icesmurf 01-28-04 04:27 AM

for all unreal games you will need to :

if using csh :

setenv LD_PRELOAD /usr/lib/tls/libGL.so.1

if using bash:

export LD_PRELOAD=/usr/lib/tls/libGL.so.1

that should allow the correct linking whilst playing unreal based games (UT, postal2 etc).


All times are GMT -5. The time now is 02:42 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.