nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Help! Can't install drivers! (http://www.nvnews.net/vbulletin/showthread.php?t=24184)

sammckee 01-28-04 09:14 PM

Help! Can't install drivers!
 
I downloaded the 5336 version. I'm running kernel 2.4.22-21mdk. I have the kernel source installed. I ran the installer, and this is what's at the end of my nvidia-installer.log:


-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
-> Kernel source path: '/usr/src/linux'
-> Performing cc_version_check with CC="cc".
ERROR: Unable to determine the NVIDIA kernel module filename.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.


Help!

ocilent1 01-28-04 09:53 PM

Yes, I am getting the exact same thing on my mandrake 9.2 box.

Specs Are:
Kernel 2.4.22-21mm.2mdk
RIVA TNT2 Model 64/Model 64 Pro

As a side note:

I also installed this driver on my 9.2 box running the 2.6.1 kernel and it installed fine, but ran like crap.

My glxgears scores go from 250fps (under the 2.4.22-21mm kernel) to about ~80fps under the 2.6.1 kernel.

I also use a small kicker applet called kcube that monitors my cpu usage and shows it via a 3d rotating cube. When running the applet under the 2.6.1 kernel with the 5336 drivers it consumes 100% CPU. This never happened with any previous 2.4.x kernel / nvidia driver combinations.

http://www.tuxed.de/kcube/

whig 01-29-04 02:01 AM

Sam: have you unpacked the kernel source tree? Point the nvidia installer to the include directory (-A brings up help).

sammckee 01-29-04 07:36 AM

How do I do that?

whig 01-29-04 06:27 PM

sh NVIDIA-Linux-x86-1.0-5336-pkg1.run -A | less

It will give you the option for specifying where your kernel source is.

StGermain 01-29-04 07:05 PM

I had the exact same problem. Extracting the package and trying 'make install' gave a more helpful error of not being able to determine the kernel version to build for. The problem was caused by having two versions of the same distro-version of the kernel installed at once.
I'm running Mandrake 9.2 and had both the regular and multimedia-version of kernel-2.4.22-26mdk . I uninstalled the one I didn't use (the mm one, which caused skipping sound and other multitasking issues for me), and -ivh --force installed the rpms of the one I actually used again just to be on the safe side.
After this it installed perfectly. I hope this helps someone....

blata 01-29-04 08:03 PM

I got mine to work.

Im runing RH 9

I rebooted into an old kernel

rpm -e kernel.2.4.20-28.9
rpm -e kernel-source

to uninstall the old kernel and source

then I

rpm -Uvh ftp://bugs.osu.edu/pub/Linux/RedHat/...kernel-source*
(my ftp site feel free to use)

then I ran up to date to install the kernel I had just uninstalled as well as update the source rpm and bingo after a reboot 5336 installed with nary an error.

sammckee 01-29-04 09:09 PM

Okay, I found my kernel source and specified that option when I ran the installer. It still said that it can't find the "NVIDIA kernel source."

So I did a little experiment: I ran it again, specifying the same option, but changed the source directory to one that does not contain the kernel source. This time it complained that it couldn't find kernel.h!

I changed it back to what it was, and it no longer complained that it couldn't find kernel.h, but complained again that it can't find the NVIDIA kernal source.

So it is finding the Linux kernel source that it needs. What it can't find is the NVIDIA kernel source. Whatever that is. And wherever it is.

On the plus side, I'm learning more about how to query packages and where to find stuff on my system than...well, I ever really wanted to know, but I'm glad I know it now.

madhead 01-29-04 09:24 PM

Just a thought but.... are you sure that you downloaded the driver without errors?

sammckee 01-29-04 09:56 PM

Not a bad idea to try, so I did. I just downloaded the 5336 driver again, overwrote my old one and ran it. Same error.

ocilent1 01-30-04 03:55 AM

I solved the issue by uninstalling all my various kernel sources from /usr/src/ and re-installing just the source I used to build my kernel. (Make sure you literally go into that /usr/src/ directory after you have removed the source rpms and manually remove any kernel source folders.)

sammckee 01-30-04 09:30 AM

I'll try that when I get home, but since I already tried explicitly pointing the installer to the correct source directory I'm skeptical.

When you say you solved the problem by doing that, were you getting the error message about its not being able to find the NVIDIA kernel source?


All times are GMT -5. The time now is 02:48 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.