nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   1.0.5336+kernel-2.6.1+debian please help! (http://www.nvnews.net/vbulletin/showthread.php?t=24231)

Coyote 01-29-04 05:43 PM

1.0.5336+kernel-2.6.1+debian please help!
 
I've tried ALL of the ways told in nvidia/minion.de/others FAQs and READMEs for installing nvidia drivers.

Xserver crashes all the time with signal 11.
What i always get is an "unresolved simbols in /usr/X11R6/lib/modules/drivers/nvidia_drv.o" messages.

I tried first using kernel 2.6.0 provided by debian, nvidia-kernel-source/nvidia-glx/nvidia-kernel-common V=1.0.5328 with minion.de patches.

Then with kernel 2.6.1 from kernel.org.
Then with kernel 2.6.1 and 1.0.5336 of nvidia drivers (debian packages).
Then with nvidia installers NVIDIA-Linux-x86-1.0-53[XX]-pkg[Y].run (XX,Y=28,0 ; 36,0 ; 36,1) uninstalling cleanly between each method.
Compile process where all ok.
Gcc = 2.95-4 (kernel and nvidia modules)
NVIDIA-Linux-x86-1.0-5336-pkg1.run
nv didn't work also, but the error pointed to other function in nv_drv.o.

My hardware is:
chipset: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333]
video: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev b2)
cpu: Athlon XP 2000+

I tried also the boot parameters acpi=off and noacpi, and "Option" "NvAgp" "1" in XF86Config-4, in all combinations with the above drivers.

Thanks a LOOOOT if anybody can help...

Coyote 01-29-04 05:45 PM

I also desactivated and also recompile kernel without any framebuffers.

The Baron 01-29-04 05:50 PM

man, I need to reinstall Slackware or give Debian a go on my machine now that there's SATA support... anyway, Andy will most assuredly tell you to rerun X with 'startx -- -logverbose 5' and post the log, so go ahead and get that up for when he sees this.

Andy Mecham 01-29-04 05:55 PM

Actually...

Getting unresolved symbols generally means your kernel source tree configuration and your running kernel are out of sync.

--andy

Coyote 01-29-04 06:43 PM

I thought of that, and also for compiling with diferent versions of gcc.
but I checked that. I just compiled kernel just once (to remove framebuffers), and after that, installing it and rebooting. Then i compiled & installed all the nvidia stuff by all ways (via nvidia installers and the debian way).
So, the runing kernel is the same as the /usr/src/linux tree.

Is there any other possible reason, or something wrong with the way I'm doing?

Andy Mecham 01-29-04 06:45 PM

Well, let's clarify - are you getting unresolved symbols when you run 'depmod -a', or in your X log?

--andy

Coyote 01-29-04 06:54 PM

In the X log.

The module doesn't give any error when adding it to the kernel.

I'll run it again to get the exact messages...

Coyote 01-29-04 07:10 PM

XFree86.0.log:

....
(II) NVIDIA XFree86 Driver 1.0-5336 Wed Jan 14 18:30:46 PST 2004
(II) NVIDIA Unified Driver for all NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Assigning device section with no busID to primary device
(WW) Symbol xf86XvMCCreateAdaptorRec from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
....etc.

Coyote 02-04-04 03:33 AM

BTW, the log shows a repeated message:

Not loading .note.GNU-stack

Coyote 02-06-04 03:25 AM

any clue about this?


All times are GMT -5. The time now is 01:37 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.