nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   1.0-5336 ,Abit KV7, Mandrake 92 and Leadtek NV28 TI4200 AGPX8 card ?? (http://www.nvnews.net/vbulletin/showthread.php?t=24233)

madhead 01-29-04 07:07 PM

1.0-5336 ,Abit KV7, Mandrake 92 and Leadtek NV28 TI4200 AGPX8 card ??
1 Attachment(s)

Until recently I had been running flawlessly on a AMD 850 MHz Athlon Thunderbird with LEADtek 4200TI 128Mb AGP 8X card on Mandrake 9.1. Wolfenstein, etwolf,quake3 and ut2003Demo2022 all run for hours without problems. (Using 1.0-4496 drivers). Even now having I dropped in my old Diamond Viper V550 in this box it still runs fine.

Now for the problem... I decided to upgrade to a new box with new motherboard Abit KV7 with the latest firmware (13), an AMD XP2500+ (barton) CPU and 512Mb PC3200 memory. (This is a KT600 chipset board) I also left in the 4200TI 128Mb AGP 8X card. I did a fresh install of mandrake 9.2 and tried in vain to get the Nvidia drivers to work (1.0-5328). With the latest release 1.0-5336 I have X up and running and 3D. However after a very short time I get a signal error Received signal 11, exiting...
Shutdown tty console from etwolf, quake3 and wolfenstein ut2003Demo also errors out after a while with a segmentation fault. I think that the KT600 chipset is not that well supported in this kernel as the agpgart module fails to load which leads me to believe that the nvidia drivers are using the NVAGP agp driver. I have disabled apic as kernel option and still no luck.

uname output is
2.4.22-26mdk #1 Wed Jan 7 10:47:21 MST 2004 i686 unknown unknown GNU/Linux
I have all of the updates available for mandrake installed including the kernel update.

This is driving me absolutely nuts I really could do with some help!
I have attached a x.log file.

(If anyone has a binary compiled Nvidia driver against this kernel that might help.)

(Its probably worth mentioning that I also have W2k3 on the same box and when running Tombraider I suffer crashes also when using DirectX excessively.)

XF86Config-4 output is as follows:-
-- BOF--
# File generated by XFdrake.

# ************************************************** ********************
# Refer to the XF86Config man page for details about the format of
# this file.
# ************************************************** ********************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"

Section "ServerFlags"
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
#DontZap # disable <Crtl><Alt><BS> (server abort)

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
#Option "XkbOptions" ""

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"

Section "Monitor"
Identifier "monitor1"
VendorName "Relisys"
ModelName "Relisys RE772"
HorizSync 30-72
VertRefresh 50-150

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616

Section "Device"
Identifier "device1"
VendorName "NVidia"
BoardName "NVIDIA GeForce4 (generic)"
Driver "nvidia"
Option "DPMS"
Option "NvAGP" "1"

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1024 768

Subsection "Display"
Depth 15
Virtual 1024 768

Subsection "Display"
Depth 16
Virtual 1024 768

Subsection "Display"
Depth 24
Virtual 1024 768

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"


lspci output :-


00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400 AGP] Host Bridge (rev 80)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:0f.0 RAID bus controller: VIA Technologies, Inc.: Unknown device 3149 (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT8233/A/C/VT8235 PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. USB (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. USB (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. USB (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. USB (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc.: Unknown device 3227
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235 AC97 Audio Controller (rev 60)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
01:00.0 VGA compatible controller: nVidia Corporation NV28 [GeForce4 Ti 4200 AGP 8x] (rev a1)

Please help I need my gaming back!!

whig 01-30-04 12:56 AM

If it's crashing Windows too it could be bad RAM. Use memtest or whatever.

madhead 01-30-04 04:14 AM

Do you mean memory in the graphics card or in comp??

saturnotaku 01-30-04 07:50 AM

Bad video memory will result in graphics corruption, not system crashes. He means system memory.

madhead 01-30-04 03:10 PM

Used memtest86 and it found errors spot on this is really annoying as it is brand new! I'll get that replaced and take it from there thanks for the advice. (I have also suffered one corruption of the graphics diplay so lets hope its not that too:-(

madhead 02-13-04 02:45 PM

Hello I'm back again I replaced the memory with some from crucial.com. tested it and fine.

I was playing rtcw quite happy when system froze solid. on 5336 drivers. When i reboot I got garbled screen when the dm service starts up. If i boot single mode switch to nv driver go to init level 3 I can startx.

If I then switch to nvidia driver and start dm again all works fine again.

If I reboot garbled screen again when dm starts.

Any help would be much appreciated. An ealier driver suggestion would be ok.

All times are GMT -5. The time now is 10:43 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.