nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Starting X takes tooooo long (http://www.nvnews.net/vbulletin/showthread.php?t=24241)

pprett 01-30-04 03:02 AM

Starting X takes tooooo long
 
1 Attachment(s)
hi, i'm using a debian woody with kernel 2.6.0. I installed the newest Nvidia driver (5xxx patched version). Everything works fine - there is only one problem: starting x takes up to 5 min!!!

CPU: Athlon XP1800
GC: GeForce3 Ti200

XFCONFIG-4:

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen "Screen0"
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
#ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
Load "dbe"
#Load "dri"
Load "extmod"
Load "glx"
#Load "pex5"
Load "record"
#Load "xie"
#Load "agpgart"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "imps/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Option "CalcAlgorithm" "CheckDesktopGeometry"
HorizSync 30-98
Identifier "Monitor0"
ModelName "PS-998"
Option "DPMS"
VendorName "PROVIEW"
VertRefresh 50-150
UseModes "Modes[0]"
EndSection


Section "Device"
Identifier "Card0"
Driver "nvidia"
#Option "NvAgp" "0"
VendorName "NVidia"
BoardName "GeForce3 (rev 1)"
BusID "PCI:1:0:0"

EndSection


Section "Modes"
Identifier "Modes[0]"
Modeline "1152x864" 146.61 1152 1200 1416 1560 864 864 879 902
Modeline "1024x768" 94.50 1024 1072 1168 1376 768 769 772 808
Modeline "1152x864" 146.61 1152 1200 1416 1560 864 864 879 902
Modeline "1280x960" 141.44 1280 1296 1552 1680 960 960 973 1003
Modeline "1280x1024" 157.50 1280 1360 1520 1744 1024 1025 1028 1072
EndSection

Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1152x864" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
Device "Card0"
Identifier "Screen0"
Monitor "Monitor0"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

pprett 01-30-04 03:04 AM

By the way window-manager is gdm - maybe this is the problem

thx, peter

Andy Mecham 01-30-04 11:50 AM

From the README:

Q: X takes a long time to start (possibly several minutes). What can
I do?

A: Most of the startx delay problems we have found are caused by incorrect
data in video BIOSes about what display devices are possibly connected
or what i2c port should be used for detection. You can work around
these problems with the XF86Config option "IgnoreDisplayDevices"
(please see the description in (app-d) APPENDIX D: XF86CONFIG OPTIONS).

--andy

ipower 01-30-04 06:57 PM

slow starting X
 
I had a similar situation. I was boggled about the solution and had nearly given up but then I found what I thought might be solutio and sure enough, it was. If you add the option

Option "NvAGP" "0"

to your XF86Config it should work. It worked for me. I had tried everything. Including

Option "IgnoreDisplayDevices" "DFP, TV"

that one did not work for me. The "NvAGP" worked great. Try it. If it works for you then great!


All times are GMT -5. The time now is 05:45 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.