nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   trouble in startx (http://www.nvnews.net/vbulletin/showthread.php?t=2427)

rahman 10-01-02 05:21 AM

trouble in startx
 
I am having a distributed version of redhat 7.1

pc with asus A7n266-VM mother board athlon 1800+ cpu

whenever i try to load x it is not getting started

i hav downloaded the all types drivers from nvidia site
and tried all combination tar,src,rpm

but i could not load the X

desperatly seeking help from tech gurus

bwkaz 10-01-02 09:29 AM

Can you post your X log?

/var/log/XFree86.0.log is the file.

rahman 10-03-02 11:15 AM

thak u need some help
 
1 Attachment(s)
Dear sir,

first of all i would like to thank you for taking interest in
solving my problem.

i have installed PCQ linux release 7.1 which is
based on red hat 7.1

the kernel shows as 2.4.2-2 om i686
first i installed the linux and tried to start X .but in
vain . then i downloaded the nvidia drivers (by tar files)thinking
that it would solve the problem .ll process in intallation went sucessfully
i also edited the XF86Config-4 file as per the document instruction
and gone through the FAQ section .but i could not find the solution
to the problem. then i searched the linux discussion from for the
problem with my mother board A&N266-VM .there also i could not find the answer bcos no body has
given the solution for this motherboard . and finally the reply come from u
i sure i will get some help from u
please find my Xfree log file as mentioned by u attached



regards rahman

rahman 10-03-02 11:16 AM

1 Attachment(s)
as i could not attach 2 files at a time i am attching my config file also here

bwkaz 10-03-02 12:42 PM

Hmm... interesting. From the X log, X is trying to load "GLcore", "dri", and "glx" (but not nVidia's GLX; the actual file it's using is libglx.a, and nVidia's is named libglx.so), and use the "nv" driver. It should be not loading "GLcore", not loading "dri", loading "glx" (.so), and using the "nvidia" driver. Which is the way the config file you've attached is set up.

Additionally, the log file says that the configuration file it's using is named /etc/X11/XF86Config-4. And the file you've attached is named xf86config-4.txt, which leads me to believe that it was this file.

Maybe I should check my assumptions first -- was the file you attached named /etc/X11/XF86Config-4 originally? That is the file that should be changed, since it's the one that X says it's using. Was the config file in this state (i.e. after you changed it, you have not run any GUI configuration tool that affects the display) when this X log was generated? The X log gets regenerated every time you try to start X up, so this log will be from the last try. The current time when the log was generated was "Tue Oct 1 22:36:09 2002", 10:36 PM on Tuesday. This seems reasonable...

What does ls /var/log/XF* print? How about ls /etc/X11? What about uname -r? (that's to find out your kernel version; if it's 2.2.xx, then the driver may not work properly, but that wouldn't cause the problems in the X log that I saw).

rahman 10-04-02 01:19 AM

rahman
 
sir i am little bit confused
first i will reinstall the linux from the begining
and i will submit u the log file may be that will eliminate your
doubts . because i was not getting the X started after the first installation. then i downloaded the nivida driver "TAR"and done as per the instruction in the readme text
my doubt was whether the NV driver supplied with the linux
distribution will work for this nvidia GEFore2 MX integrated GPU

because what it was told in manual is "once your X is working then do this change"
and i dont know if X itself is not working how to go about it

the kernel version what it shows isin uname -r is"2.4.2-2 on i686"

rahman 10-04-02 10:43 AM

after trial
 
1 Attachment(s)
please find the following files details i am attaching here with
as asked by you.
the command 'uname -r 'prints out "2.4.2-2"
now i run Xconfigurator and copied the log &message and config files which are availble in

/var/log and /etc/X11 directories respectively.
1.XFree86.9.log
2.XF86Config-4.old
3.XF86Config.old

then i edited the XF86Config-4 file as per the driver
documentation and started X by "startx" and corresponding log files are
1. XFree86.0.log
2. XF86Config-4
3. XF86Config
4. messages

in addition to this i am giving my system configuration

1.CPU - AMD Ahtlon 1800+
2. Motherboard ASUS A7N266-VM
THIS MOTHERBOARD has
North Bridge Chipset : nvidia 220D GeForce MX integrated GPU
South bridge : nVidia nForce MCP-D integrated peripheral south bridge controller
and Dolby Integrated Audio.
3. seagate barracuda 40GB partitioned as C,D,E,F,(G- linux root+ swap)
where G drive i deleted during installation and made for linux native and swap.

In C drive i have windows98 and i am using XOSL extended boot loader
for loading both windows and linux . kindly advice me which version of
linux i should use to get the problem solved

bwkaz 10-04-02 11:06 AM

OK, now it's making more sense. The XFree86.0.log file says that X is loading all the proper drivers and extensions, and that matches the config file. So that end of things is fine.

The problem now is that the kernel module (NVdriver) isn't being loaded. To fix it until you reboot, just do a modprobe NVdriver (as root) and try to start X again. Unfortunately, this only works until you shut down. You have to edit the /etc/modules.conf file to make it load automatically whenever it's needed.

Your distro is based on RH 7.1 you said, so I don't believe you're running devfs (although I could be wrong). To find out for sure, do a [ -c /dev/.devfsd ] ; echo $? -- if that prints out a 1, then you are not running devfs. If it prints out a 0, then you are.

If you are running devfs, then make sure a line looking like alias /dev/nvidia* NVdriver is in your /etc/modules.conf file. If it isn't there, add it.

If you are not running devfs, then the alias line should look like alias char-major-195 NVdriver instead.

From the looks of things, it's either the case that the wrong line got put into modules.conf by the driver, or that neither one got put in there by it. My guess is that neither line got put there, because I've had that happen a lot of times to me.

Your kernel version (2.4.2-2) looks fine. It's a little old (there's a 2.4.19 out now), but not old enough that it won't work.

rahman 10-07-02 04:45 AM

Thanks a lot
 
Dear sir ,

I am very much delighted to see my
system worked with nVidia drivers atlast
it worked with insmod ./NVdriver


once again a looooooooot of thanks

sir one more problems is there its my nvidia integrated
sound card its dolby digital . i tried use nvidia nfore drivers
which is available in nvidia's site .but it did not worked
what the nforce driver is having is i810 audio and a network
driver ,but when i tried to intall it i m getting unresolved symbols when i tried to use tar intallation.
one again thanks a lot

:)

bwkaz 10-07-02 06:47 AM

I've never used the nForce drivers, so I really don't know what to try. Maybe someone else reading this thread does?

*looks around hopefully*

rahman 10-16-02 03:52 AM

hank you oince again bkwaz i got the drivers from
alsa website and configured it successfully

bwkaz 10-16-02 06:50 AM

Congratulations! Glad to hear you got it working.


All times are GMT -5. The time now is 03:42 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.