nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   SuSE 8.2 & nVidia 3D setup problem (newbie) (http://www.nvnews.net/vbulletin/showthread.php?t=24270)

grahamp 01-30-04 03:12 PM

SuSE 8.2 & nVidia 3D setup problem (newbie)
 
1 Attachment(s)
I have recently bought an XFX GeForce4 MX440 AGP 8X 128Mb graphics card which works perfectly in Win 2000 (and with very little effort!).
In SuSE 8.2 (Kernel 2.4.20-4Gb-athlon), it works fine in 2D, but I can't work out what I'm meant to do to get 3D working properly. I have been working on driver version 1.0.4496, as earlier messages suggested that the later one may not work properly.
The MB is an Asus A7V133-c, with Athlon 1600 processor.
With the NVIDIA Installer, I have managed to create anv-linux.o file, but can't work out what to do with it.
The instructions say" mkprecompiled --interface=nv-linux.o --output=nv-linux.o.........mv nv-linux.o-mykernel precompiled/"

I don't understand this at all.:confused:

Is there an idiot version of what I need to do to get it to work on my system? I suspect that, having the nv-linux.o file that it isn't that far off being useable, but haven't the slightest idea as to what it might be.

I attach the XFree86.0.log and XF86Config.log files if it helps.
I'm fairly new to linux, so anything above idiot level may not mean much ;)

Thanks, Graham

whig 01-30-04 06:30 PM

It seems to me you are not following nvidia's install instructions. They boil down to "sh NVIDIA...run" and let it do the work.

DisastersMaster 01-31-04 04:23 AM

Hello.
For the installing the driver under SuSE Linux 8.2 exists a help-file in german. The link you can find in the download- area of the drivers.

Here in short- form, what stands in this file:

- close your X- session
- jump to console 1 (Ctrl+ Alt+ F1)
- login as root
- switch to runlevel 3 (init 3)
- cd- ing to /usr/src/linux (cd /usr/src/linux)
- command: make cloneconfig && make dep
- cding in the directory, where the file was downloaded ( for example cd /home/disastermaster/public_html/drivers/nvidia)
- sh NVIDIA-Linux-x86-1.0-5336-pkg1.run
- run sax with special options (sax2 -m 0=nvidia [0 is a digit, not a letter! and it stands for the slot where the card is in)
- and now, its very important! let stand the monitor on 60 Hz !
- test the server, correct the picture
- edit the file /etc/X11/XF86Config with an editor (for example joe /etc/X11/XF86Config)
- search the section Section "Monitor" and edit the lines with HorizSync und VertRefresh (for example
HorizSync "31-60"
VertRefresh "50-75"
- save the file (joe= Ctrl+k+x)
- switch to runlevel 5 (init 5)

Thats all.

cu

disaster

grahamp 01-31-04 03:43 PM

Hi again,

when I tried to run the nvidia installer using sh....run as suggested by whig, I got the following error message (or something very similar):

"-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
-> Kernel source path: '/usr/src/linux'
-> Performing cc_version_check with CC="cc".
ERROR: Unable to determine the NVIDIA kernel module filename.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com."

As I was in runlevel 3, I couldn't connect to the internet to go to the ftp site, and there isn't a /usr/src/linux directory. I looked on the nvidia site, but couldn't find what I needed.

The lack of the directory (I do have /usr/src/ ,just no linux directory) also means I can't try DisasterMaster's suggestion, unfortunately, so I'm no further forward.

:confused:

Thanks for the suggestions, but still not cracked it, yet, I'm afraid,
Graham :(

PS have attached XF86Config.log, just in case it is helpful

whig 01-31-04 04:25 PM

Unpack your kernel source - type:

uname -a

... this will give you your kernel version. Find the corresponding source package and go from there.

grahamp 02-01-04 04:01 PM

Sorry, still completely lost.

uname -a gives me the kernel name (2.4.20-4GB-athlon).

Do I need to install a new kernel now?

I have cd'd to usr/src & the only subdirectory there is "packages" - nothing with the name of the kernel in it at all (or even a reference to linux-2.4.20....

Not sure I understand " Find the corresponding source package and go from there." From where? Then what?

Still fairly "green" with linux - used DOS in about 1988, but moved on to XP at home and have forgotten most of what I ever knew with DOS ages ago.

Whilst I know it's very powerful, getting used to command line again is taking some getting used to, especially when I'm not sure what I'm doing (or why!!)

cheers,
Graham


All times are GMT -5. The time now is 04:46 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.