nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Games Cant Find OpenGL (http://www.nvnews.net/vbulletin/showthread.php?t=24303)

nashirak 01-31-04 12:30 PM

Games Cant Find OpenGL
 
Hey I am using the 5328 drivers. I tried installing the 5336 drivers but I kept getting errors like:
ERROR: Unable to determine the NVIDIA kernel module filename.

And yes all the source packages were installed linked etc. It appears some other ppl are having trouble with it as well:

http://www.nvnews.net/vbulletin/show...threadid=24184
http://www.nvnews.net/vbulletin/show...threadid=24242
http://www.nvnews.net/vbulletin/show...threadid=24133

so its not just me:

http://www.nvnews.net/vbulletin/show...threadid=24225

A bug mabye?

Anyway I got the 5328 drivers to install without a hitch. I am having problems though running games (Armyops and UT and UT2003). They cant seem to load the OpenGL drivers. I have checked my /usr/lib/ to make sure the libGL files are there it returns:

libGL.la
libGL.so -> libGL.so.1
libGL.so.1 -> libGL.so.1.0.5328
libGL.so.1.0.5328
libGLU.a -> ../X11R6/lib/libGLU.a
libGLU.so -> libGLU.so.1.3
libGLU.so.1 -> libGLU.so.1.3
libGLU.so.1.3 -> ../X11R6/lib/libGLU.so.1.3
libGLcore.so.1 -> libGLcore.so.1.0.5328
libGLcore.so.1.0.5328

I can also run glxgears and get around 1800 fps.
glxinfo does return information as well. I used to be able to run these games before I updated my NVIDIA drivers. Any thoughts?

(XFree86 config is attached, system is a debian Geforce3 card 64mb)

Thx


# XFree86 4.0 configuration generated by Xconfigurator

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

# By default, Red Hat Linux 6.0 and later use xfs

Section "Files"
FontPath "unix/:7100"
EndSection

# This loads all the modules...

Section "Module"
Load "dbe"
Load "extmod"
Load "glx"
# Load "pex5"
Load "record"
Load "xie"
Load "v4l"
Load "type1" #added to make abi work
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Device" "/dev/mouse"
Option "Protocol" "ExplorerPS/2"
Option "Buttons" "7"
Option "ZAxisMapping" "6 7"
Option "Resolution" "640"
EndSection

Section "Monitor"
Identifier "Princeton EO900"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30 - 95
VertRefresh 50 - 160
EndSection

Section "Device"
Identifier "nVidia Corporation|NV15 (Geforce2 GTS)"
# Driver "nv"
Driver "nvidia"
Option "NvAgp" "1"
VideoRam 65536
# BusID "PCI:1:0:0"
BoardName "Unknown"
EndSection

Section "Screen"
Identifier "Screen0"
Device "nVidia Corporation|NV15 (Geforce2 GTS)"
Monitor "Princeton EO900"
DefaultDepth 24
Subsection "Display"
Depth 32
# Modes "1600x1200"
Modes "1280x1024"
Modes "800x600"
EndSubSection
Subsection "Display"
Depth 24
# Modes "1600x1200"
Modes "1280x1024"
Modes "800x600"
EndSubSection
Subsection "Display"
Depth 16
# Modes "1600x1200"
Modes "1280x1024"
Modes "800x600"
EndSubSection
EndSection

#Section "DRI"
#Mode 0666
#EndSection

whig 01-31-04 04:40 PM

Does lsmod show the nvidia kernel module is loaded? If not, modprobe it and startx.

nashirak 01-31-04 07:41 PM

Yes lsmod shows this:

nvidia 1969728 14
nls_iso8859-1 2844 0 (autoclean)
isofs 24184 0 (autoclean)
smbfs 31840 1 (autoclean)
sr_mod 11824 0 (autoclean)
cdrom 27072 0 (autoclean) [sr_mod]
parport_pc 20872 1 (autoclean)
lp 5888 0 (autoclean)
parport 22880 1 (autoclean) [parport_pc lp]
binfmt_misc 5500 1
apm 8840 2 (autoclean)
af_packet 11560 0 (autoclean)
nls_cp437 4348 2 (autoclean)
vfat 9276 1 (autoclean)
fat 29080 0 (autoclean) [vfat]
visor 10188 3
usbserial 17756 0 [visor]
usb-storage 48120 0 (unused)
usb-uhci 20972 0 (unused)
usbcore 54592 1 [visor usbserial usb-storage usb-uhci]
emu10k1 52200 1
ac97_codec 9576 0 [emu10k1]
sound 52140 0 [emu10k1]
soundcore 3492 7 [emu10k1 sound]
ide-scsi 7344 0
scsi_mod 86072 3 [sr_mod usb-storage ide-scsi]
8139too 13576 1
mii 1088 0 [8139too]
rtc 5692 0 (autoclean)
ext2 30624 1 (autoclean)
ide-disk 9280 3 (autoclean)
ide-probe-mod 8496 0 (autoclean)
ide-mod 148968 3 (autoclean) [ide-scsi ide-disk ide-probe-mod]
ext3 56896 0 (autoclean)
jbd 35736 0 (autoclean) [ext3]
unix 13288 239 (autoclean)

nvidia being in there. Strange thing is that Enemy Territory works but Unreal Tournament based games dont work (like Army Ops, UT2003, and UT Classic). By the way here is what glxinfo returns:

name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.3
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,
GLX_ARB_multisample
client glx vendor string: NVIDIA Corporation
client glx version string: 1.3
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_visual_info,
GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_SGI_video_sync,
GLX_NV_swap_group, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
GLX_SGI_swap_control, GLX_NV_float_buffer
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,
GLX_ARB_multisample, GLX_ARB_get_proc_address
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce3/PCI/3DNOW!
OpenGL version string: 1.4.1 NVIDIA 53.28
OpenGL extensions:
GL_ARB_depth_texture, GL_ARB_imaging, GL_ARB_multisample,
GL_ARB_multitexture, GL_ARB_occlusion_query, GL_ARB_point_parameters,
GL_ARB_point_sprite, GL_ARB_shadow, GL_ARB_texture_border_clamp,
GL_ARB_texture_compression, GL_ARB_texture_cube_map,
GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
GL_ARB_transpose_matrix, GL_ARB_vertex_buffer_object,
GL_ARB_vertex_program, GL_ARB_window_pos, GL_S3_s3tc,
GL_EXT_texture_env_add, GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_compiled_vertex_array,
GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_multi_draw_arrays,
GL_EXT_packed_pixels, GL_EXT_paletted_texture, GL_EXT_point_parameters,
GL_EXT_rescale_normal, GL_EXT_secondary_color,
GL_EXT_separate_specular_color, GL_EXT_shadow_funcs,
GL_EXT_shared_texture_palette, GL_EXT_stencil_wrap, GL_EXT_texture3D,
GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map,
GL_EXT_texture_edge_clamp, GL_EXT_texture_env_combine,
GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
GL_EXT_texture_lod, GL_EXT_texture_lod_bias, GL_EXT_texture_object,
GL_EXT_vertex_array, GL_HP_occlusion_test, GL_IBM_rasterpos_clip,
GL_IBM_texture_mirrored_repeat, GL_KTX_buffer_region, GL_NV_blend_square,
GL_NV_copy_depth_to_color, GL_NV_depth_clamp, GL_NV_fence,
GL_NV_fog_distance, GL_NV_light_max_exponent,
GL_NV_multisample_filter_hint, GL_NV_occlusion_query,
GL_NV_packed_depth_stencil, GL_NV_pixel_data_range, GL_NV_point_sprite,
GL_NV_register_combiners, GL_NV_register_combiners2,
GL_NV_texgen_reflection, GL_NV_texture_compression_vtc,
GL_NV_texture_env_combine4, GL_NV_texture_rectangle, GL_NV_texture_shader,
GL_NV_texture_shader2, GL_NV_vertex_array_range,
GL_NV_vertex_array_range2, GL_NV_vertex_program, GL_NV_vertex_program1_1,
GL_NVX_ycrcb, GL_SGIS_generate_mipmap, GL_SGIS_multitexture,
GL_SGIS_texture_lod, GL_SGIX_depth_texture, GL_SGIX_shadow,
GL_SUN_slice_accum
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

whig 01-31-04 08:32 PM

It gets harder to solve then :( You have Option "NvAgp" "1" - try 0 or 2 and see if you can play UT.

nashirak 02-01-04 08:06 AM

I have tried setting all my NvAGP settings to 0-2 and the same thing occurs.

Any other ideas?

nashirak 02-01-04 03:26 PM

SOLUTION!!!!

I appear to have hit a documented debian/nvidia bug. My solution? Remover the directory /usr/lib/tls/ it appears that my debian system doesnt like this. Once this was removed everything worked like a charm.

For reference on this see:

http://www.mail-archive.com/debian-u.../msg79858.html

Thanks for your help!


All times are GMT -5. The time now is 10:55 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.