nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Help Installing driver (http://www.nvnews.net/vbulletin/showthread.php?t=24306)

dns 01-31-04 01:48 PM

Help Installing driver
 
I'm brand new to Linux, I just wanted to try out a new OS other than Windows, as I know linux is better :) My problem is when I "startx" in console (Redhat 7.3) it does IO error 104 and all that good stuff. So I'm not sure how I go about doing this but I burned a linux video driver onto CD and I'm trying to install it from there. I tried doing cd /mnt/cdrom but no files displayed. (ls command) If anyone could help me with this it would be greatly appreciated, Thanks.

Graphics Card: GeForce FX 5200 256 MB
Processor: 3.0 Ghz 800 Mhz FSB
Video Card Driver: Not sure, default one? Never installed driver I believe.

iSteve 01-31-04 02:11 PM

"all that good stuff" ?

"I tried doing cd /mnt/cdrom" ... a bonus would be mounting it first ... ie. mount /dev/device_that_belongs_to_the_cdrom /mnt/cdrom

dns 01-31-04 02:18 PM

on IO Error 104 its just like everyone elses... no screens found mostly and contact them. I'm sorry I don't understand what you mean by device that belongs to cd-rom, Like D:/ drive?

thanks for the help though steve

dns 01-31-04 02:53 PM

ok scratch that I got my cd-rom mounted but I'm having a problem running the file. it says this when I run it,

"Unable to find the system utility "ld" ; please make sure you have the package "binutils" installed. if you do have binutils installed, then please check that "ld" is in your PATH.

DarkMachine 02-02-04 06:43 AM

in general
 
in order to read anything from the cdrom it has to be mounted with a command like this

mount /mnt/cdrom

then you can cd to /mnt/cdrom and there will be somthing there. once you have this done i belive that the NVidia ".run" file must be copied to yoru hard drive in order for it to build and install, this is because your cdrom is a read-only file system. so

sh NVIDIA(version info).run

and that shoudl take care of it...except you need to open the file

/etc/X11/XF86Config and edit the line that says

driver "nv" to say driver "nvidia"

then try starting X

Moled 02-02-04 08:07 AM

make sure you have gcc, binutils, and your kernel headers installed

dns 02-03-04 06:34 PM

This is probably a really stupid question but... How exactly do I save my changes when I edited XF86Config? I'm in a text editor that let me change it around a little bit, not the command XF86Config

Moled 02-03-04 07:23 PM

which editor?

dns 02-04-04 05:06 PM

I believe i used the command vi /etc/X11/XF86Config

learninglinux 02-04-04 05:59 PM

save change to XF86config in vi
 
Hello dns,

Just type ":wq", then press the enter key.
1) ":" is for changing to command mode from insert mode.
2) "w" is for write (means updating/saving) your current file.
3) "q" is for quitting the vi editor.

If you just want to save without leaving vi, then just
type ":w".

Regards,
learninglinux
(a linux newbie)


All times are GMT -5. The time now is 02:12 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.