nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   5336 / 2.6.2-rc3 / 4.3.0 / Debian = segfault when starting Xserver (http://www.nvnews.net/vbulletin/showthread.php?t=24325)

m2- 02-01-04 08:26 AM

5336 / 2.6.2-rc3 / 4.3.0 / Debian = segfault when starting Xserver
 
See subject.

1.0.5336 + 2.6.2-rc3 on a Debian system with XFree86 4.3 produces a segfault when starting the Xserver. This is a Dell Inspiron 8000 laptop. The driver seems to be happy in 2.4.24. I have flashed the BIOS to the newest available from Dell ('cus of an unrelated kernel message), I have tried with and without ACPI, with AGPGART and with the driver's internal AGP support, same thing. The Xserver segfaults after "initializing GLX extension".

Clues?

m2- 02-01-04 08:27 AM

Ah, yes, I have read this forums. And I tried the suggestions at http://www.minion.de/ just in case. No change.

zander 02-01-04 08:34 AM

Reinstall the driver on Linux 2.6, the problem should go away then.

m2- 02-01-04 09:09 AM

What do you mean "reinstall the driver in 2.6"? The kernel module is working properly. It loads without fuss. It's the Xserver that's segfaulting.

zander 02-01-04 10:40 AM

Recent versions of glibc (as shipped by several distributions, including Debian GNU/Linux (unstable)) support NPTL enabled kernels, i.e. they will behave differently on Linux 2.6 than they do on vanilla Linux 2.4 kernels. The fact that your X server is segfaulting during GLX initialization on Linux 2.6 whereas it works fine on Linux 2.4 suggests that you don't have the correct set of NVIDIA OpenGL libraries installed.

energyman76b 02-01-04 02:38 PM

Hi,

I had problems with nptl&nvidia drivers, giving me an SIGFPE on startup. I had to clean my system from nptl (rebuilding a lot of stuff), after that, everthing is ok.

m2- 02-01-04 06:36 PM

After noticing that there are TLS versions of the glx module, too (makes zero sense to me), I replaced the non-TLS version in /usr/X11R6/lib/modules/ with the TLS version and everything works. Thanks!

Now for a question regarding understanding the situation, I hope someone from NVIDIA is willing to explain what's going on here. If the glx module is loaded by the X server, which is not threaded, why does it matter which threading model the module uses? And why does it segfault during X server initialization. The only thing I can figure right now, is that the X server uses this for indirect rendering, but that doesn't explain the problem to me. In short: why does it make a difference if the glx module is using TLS or not?

(it's pretty annoying to have to switch between the TLS and the non-TLS version when changing kernels -- but that's something else)

To zander: jein. You are right in that the non TLS module was being used. But the problem is not the GL libraries, but the glx module for the X server.

For future reference for other people: if you are using a 2.6 kernel _and_ a TLS-capable libc, check which version of the modules your X server is using.

zander 02-02-04 04:29 AM

The NVIDIA GLX module was implied in "the correct set of NVIDIA OpenGL libraries", but this is also documented in the README.


All times are GMT -5. The time now is 10:10 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.