nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nvidia module doesn't demand load (http://www.nvnews.net/vbulletin/showthread.php?t=24347)

kgroombr 02-01-04 04:09 PM

nvidia module doesn't demand load
 
I loaded a new system and have installed kernel to 2.6.1.

I am using module-init-tools 3.0-pre9.

Here are the relevant lines in my modprobe.conf file:

alias char-major-195-* nvidia
options nvidia NVreg_EnableAGPFW=1 NVreg_EnableAGPSBA=1

I have also tried:

alias /dev/nvidia* nvidia

The nvidia module never loads upon X loading, however, if I perform and "modprobe nvidia" and then start X, all is fine.

This isn't the first time I have done this. I have two boxes set up like this (except the kernel is 2.6.0-testX and they work fine.

Thanks,
Ken

whig 02-01-04 06:47 PM

I've got the same problem on Mandrake 9.2 for AMD64 with kernel 2.6.1. I just put nvidia in /etc/modprobe.preload

zander 02-02-04 04:35 AM

You could embed an alias in the kernel module itself (MODULE_ALIAS_CHARDEV_MAJOR), but alias char-major-195* nvidia should work, as well.

rednuht 02-16-04 06:57 AM

same problem
 
yep, since upgrading to 2.6.2 (with mod-utils)
get exactly the same problem, not exactly a show stopper but damned annoying

zander 02-16-04 07:37 AM

Have you tried either one of my suggestions? If not, what error messages (if any) does modprobe produce?

kgroombr 02-16-04 07:49 AM

My first solution was that I put a line in my rc.local to load it.

My second solution was that I then created an entry in the modprobe.preload. I left it like this.

I looked for some good documentation on the new modprobe.conf file format and also on modprobe.preload. Anybody know of a link that descibes all the possible modprobe.* files and their formats?

Thanks,
Ken

prat 02-16-04 12:02 PM

Hmm... don't have a link, per se, but my autoloading works (it's NOT in any preload files, and loads succesfully on demand), so this might help:

In my /etc/modprobe.conf, I have the following lines I think are relevant:

alias char-major-195-* nvidia
alias /dev/nvidiactl nvidia

Hope that helps. Also please not I'm not using devfs (using udev, but since udev doesn't support loading modules when you try to access a /dev entry, that should be irrelevant, except insofar as the /dev/nvidiactl device does NOT go away on reboot, and though /dev is mounted on a ramfs on my system, the directory is tarred on shutdown and untarred on boot, so it's a static entry, more or less). This also means I have /dev/nvidia[0-7] devices created before the module is ever loaded, so this might have something to with it.


All times are GMT -5. The time now is 01:22 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.