nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Kernel Module install woes. (http://www.nvnews.net/vbulletin/showthread.php?t=24485)

archlyn 02-04-04 03:25 PM

Kernel Module install woes.
 
I downloaded the newest nvidia drivers (1.0.5336) and went to install them,only to find that they couldn't install the kernel module (it goes through building the interface fine and then chokes).

if I run the NVIDIA installer with the --kernel-name= option, then the module is built and supposedly installed, but if you start X using the new nVidia driver then X crashes saying that it couldn't initilize the module

I tried to do

root@localhost:~# insmod /lib/modules/2.6.2/kernel/drivers/video/nvidia.ko

and got

insmod: error inserting '/lib/modules/2.6.2/kernel/drivers/video/nvidia.ko': -1 Invalid module format

During the install procedure, I had to add the --kernel-name= commandline option in order to get it to build the kernel modules

Help please!

I'll post my xfree86 log in a sec, right now I'm using the default nv xfree86 driver

archlyn 02-04-04 03:33 PM

here's the log.
 
1 Attachment(s)
Apparently you can't edit posts to attach files, here's the log:

zander 02-04-04 04:27 PM

Check the output of dmesg for additional error messages after the X startup failure - chances are the kernel detected a kernel version magic mismatch (e.g. a compiler mismatch).

archlyn 02-04-04 05:44 PM

1 Attachment(s)
Your right, there were magic version mismatches:

Code:

nvidia: version magic '2.6.2 SMP preempt K7 gcc-3.2' should be '2.6.2 SMP preempt K7 gcc-3.3'
nvidia: version magic '2.6.2 SMP preempt K7 gcc-3.2' should be '2.6.2 SMP preempt K7 gcc-3.3'

How do I fix them? I compiled the modules with the same version of gcc. The kernel modules were compiled only an hour or so after compiling and installing the new kernel.

Just in case, I'll attach a copy of my dmesg output

zander 02-05-04 03:23 AM

You didn't build nvidia.ko with the same compiler - if you had, the kernel would have loaded the module just fine. Make sure that gcc -v returns the desired versions or use CC to specify the correct compiler.

archlyn 02-05-04 07:07 AM

How do I do that? (I assume CC is a command that must be run?) Can you (or someone else) post an example of this?

zander 02-05-04 07:14 AM


# cat /proc/version
Linux version 2.6.2-bk1-ck1 (root@wolf) (gcc version 2.95.4 20011002 (Debian prerelease)) #1 SMP Thu Feb 5 11:39:20 CET 2004
# gcc -v 2>&1 | tail -1
gcc version 3.3.3 20040125 (prerelease) (Debian)
# gcc-2.95 -v 2>&1 | tail -1
gcc version 2.95.4 20011002 (Debian prerelease)
# CC=gcc-2.95 sh NVI...


All times are GMT -5. The time now is 04:05 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.