nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Redhat 8.0, no rpm, can't compile. (http://www.nvnews.net/vbulletin/showthread.php?t=2451)

Ironphil 10-01-02 10:06 PM

Redhat 8.0, no rpm, can't compile.
 
Hi, I just installed Redhat 8.0 and I want to enable 3d by installing the nvidia drivers. There is no rpm for the kernel so far. This is not a problem since it is easy to compile but for a reason I don't know, it doesn't work. I get something like that:

make: *** [nv.o] Error 1

This is with the tar.gz, I also tried with the .src.rpm and it also doesn't work. Had no problem with Mandrake 9.0.

Anyone installed the drivers on Redhat 8.0?

bwkaz 10-01-02 10:25 PM

What are the ten or fifteen lines before "make: *** [nv.o] Error 1"?

OK, we can see there's been an error, but ... err ... we can't tell what it was.

If you want, you can make >log.txt 2>&1 and attach the resulting log.txt file to your next post, that way you'd be sure to catch the error (you'd catch all the output).

At a guess, I'd say you need to install kernel-source. But that's purely a guess, based on the number of times it fixes problems -- I would need to see the actual error that gcc is giving to be able to know for sure.

g=D 10-01-02 11:34 PM

Same problem
 
I have the same problem... I think it might be because RH8 is based on gcc 3.2... I might be dead wrong however. Tried to attach a tarball, board didn't like it.

Mostly it's a bunch of errors like:
/usr/src/linux-2.4/include/linux/kernel.h:60: invalid suffix on integer constant
usr/src/linux-2.4/include/linux/module.h:187: parse error before numeric constant

Ironphil 10-02-02 06:13 AM

Redhat 8.0, no rpm, can't compile
 
1 Attachment(s)
Here is the log file of the compile, I hope it helps.

By the way, I don't think it is related to GCC 3.2 since Mandrake use it too and I had no problem.

Ironphil 10-02-02 06:22 AM

It works!
 
Just installed the kernel development packages and I tried with both the tarball and the src.rpm and it works great. Thanks for the suggestion about the kernel sources and stuff like that.

woffutt 10-02-02 07:00 AM

Got time to email the procedure to a noob? :)
 
You'd be helping the cause... *grin*

g=D 10-02-02 03:13 PM

Corrupt dev rpms maybe
 
I'm beginning to think my kernel rpms are bad. It wouldn't build the kernel on a fresh install but it would build a vanilla just fine, along with the driver.


All times are GMT -5. The time now is 06:04 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.