nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Linux(FC1) crushes when I restart or shutdown with TV-out activated (http://www.nvnews.net/vbulletin/showthread.php?t=24548)

gvsl 02-06-04 04:51 AM

Linux(FC1) crushes when I restart or shutdown with TV-out activated
 
1 Attachment(s)
My configurations is:
MB: 8RDA+ (latest bios)
CPU: XP2400+(180x12.5)
CV: MSI GEFORCE 4 4200 64MB (with AGP 4X)
Driver Vesion: 5328 ( I try 5336 too)
Distribution: Fedora Core (2.4.22-1.2115.nptl)
Video BIOS revision: 04.25.00.29.10

SB Audigy 2 ( with FC1 driver)
TvTuner Pinnacle PCTV Pro ( with FC1 driver)
I connected my tv-out to my TV in RCA connector.

If tv-out is deactivated linux restarts, shutdown or logout without any problems. EX. After X shutdown my monitor goes into mode text ( into 720x400 resolution ), it shows the processes which are closed and restart.
After X starts if I modify the XF86Config option "TwinView" from "0" into "1" and than restart X (CTRL+ALT+Backspace) the tv-out works perfectly until I try to restart, shutdown or logout when my CRT and my TV goes black and my keyboard and my mouse are not working anymore. After this the monitor resolution is 720x400 too ( I see this in my monitor menu). If I reset my computer Linux will crush when X is started ( not always).
The same problem apears if I login in text mode and than I start X with tv-out activated. Linux and tv-out will work perfectly until I restart, shutdown or logout.
Or if I login in X with tv-out deactivated and I modify the XF86Config to activate tv-out and than I restart Linux, Linux will start with no problem and than if I restart it will crush.
I try the command "init 3" after I login in X with tv-out activated but I get the same problem.

Thanks in advance.

The Daan 02-06-04 05:31 AM

I had a similar problem, and a lot of other people, and for me the solution was to add the following line in your lilo.conf (assuming you're using lilo):

vga = 0x0317

Run lilo again, reboot and see if that worked.
For me, I was able to watch tv-out and reboot/shutdown/logout without crashing my pc again.

gvsl 02-06-04 05:36 AM

Quote:

Originally posted by The Daan
I had a similar problem, and a lot of other people, and for me the solution was to add the following line in your lilo.conf (assuming you're using lilo):

vga = 0x0317

Run lilo again, reboot and see if that worked.
For me, I was able to watch tv-out and reboot/shutdown/logout without crashing my pc again.

I am using GRUB.
Do you know a simillar command for it ?

The Daan 02-06-04 06:00 AM

From the GRUB manual (u can read that too u know ;) ) it's something like 'vga=..'

Try it, I'm not a grub user so can't help you any further with this.

gvsl 02-09-04 05:18 AM

1 Attachment(s)
It didn't work.

My lilo.conf file is this:
--------------------------
prompt
timeout=20
default=WindowsXP
boot=/dev/hda
vga=0x0317
map=/boot/map
install=/boot/boot.b
lba32

image=/boot/vmlinuz-2.4.22-1.2115.nptl
label=l
initrd=/boot/initrd-2.4.22-1.2115.nptl.img
read-only
append="rhgb root=LABEL=/"

other=/dev/hda2
optional
label=WindowsXP
--------------------------
I try
append="rhgb root=LABEL=/ vga=0x0317"
too, but it has the same effect.

The only change was that now linux starts in 1024x768 resolution in text mode and if I login in text mode and I use the commands init 5 or startx and after this I want to return in text mode with the command init 3 I can see only rectangulars in colors almoust all over the screen. But the system is functionaly because the keyboard works and if I give the command init 6
the system will restart.
With tv-out deactivated linux works perfectly.

I have attached an archive which contains my XFree86.0.log witch was created when I start with tv-out deactivated and another file which contains the 3 final lines from 3 XFree86.0.log files which were created when I start linux with tv-out activated.
Linux didn't crash at the same place each time.

gvsl 02-11-04 02:26 AM

Did somebody try to use tv-out in Fedora Core 1 ?

whig 02-11-04 07:52 AM

I was sometimes having freezes on closing X, hasn't happened since 2.4.23.

gvsl 02-13-04 01:34 AM

Quote:

Originally posted by whig
I was sometimes having freezes on closing X, hasn't happened since 2.4.23.
I tried 2.6.2 .
No effect.

gvsl 02-16-04 06:26 AM

I have installed Mandrake 9.2 (kernel 2.4.22) and just nvidia display driver.
Now I can restart the computer with tv-out activated and it doesn't crush but when I restart the computer the image disappears until all processes are closed and in this time my monitor tells me that I have a refresh of 30Hz ( under the minimal limit of the monitor).
Anyway I have tv-out now :) .


All times are GMT -5. The time now is 01:55 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.