nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Onboard LAN (http://www.nvnews.net/vbulletin/showthread.php?t=24551)

pantner 02-06-04 06:12 AM

Onboard LAN
 
Ok, i have just (about 2 days ago) installed RedHat 9.0....

And im trying to get my Onboard LAN to work....

I have the Mercury KNU400X-L Mainboard with the Nforce2 Chipset....

I have downloaded and installed the

"NVIDIA_nforce-1.0-0261.rh90up_2.4.20_6.athlon.rpm" drivers, but i still can't get it to work....when i try to add in the ethernet device its not in the list of network cards...

What (if anything) am i doing wrong???

pantner 02-08-04 06:51 AM

so.....should i give up now????

can nobody help me????

spolarium 02-08-04 08:37 AM

What's your kernel version? If it's 2.4.20-8 like mine (at a terminal, type uname -r, and you'll know your kernel version), then the driver you downloaded is not compatible with your kernel.

You have to download the source rpm labeled as NVIDIA_nforce-1.0-0261.src.rpm, http://download.nvidia.com/XFree86/n...0-0261.src.rpm and compile it. The command is rpmbuild --rebuild (filename above). Then install the compiled rpm with the rpm -ivh command.

After compilation, check out the last lines as it will show where the compiler placed the compiled driver for your kernel. Then install this instead.

Do this in a terminal window, type su -, then type your root password, then compile the source rpm. Download or read the HTML help file for better clarification.


Check out your /etc/modules.conf and see if alias eth0 nvnet is included in this configuration. I use gedit to view the config file.

Read carefully the HTML, http://download.nvidia.com/XFree86/n..._1.0-0261.html

Is your lan card enabled in the BIOS?

pantner 02-08-04 07:59 PM

Thanks spolarium, thats just what i needed!!!

spolarium 02-08-04 09:34 PM

Glad to be of help I had the same problem :).

michael286 02-09-04 07:31 PM

I have tried the rpmbuild function, and I get alot of output that says dereferencing points to incomplete type. . .

then at the end it says bad exit status from and rpm.tmp file. I assume that it did not build correctly any ideas on how I could fix this so I can get my lan working?

pantner 02-12-04 06:36 AM

i tried the rpm -rebuild ****.rpm
and the rpmbuild -rebuild ****.rpm
commands and neither worked!!!

i put the "alias nvnet eth0"
line in that file (im on my windows system, so i can't check specifics.....) and it shows up in the network config ok, but when i try to activate it it says the device is not connected or something.....

should i format my H/D and reinstall RedHat, cause i might have messed it up a little with the first drivers that i tried to install...


All times are GMT -5. The time now is 12:30 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.