nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   linux 2.6.2 -- 5336 kernel compile error (http://www.nvnews.net/vbulletin/showthread.php?t=24697)

Turtle 02-09-04 07:32 PM

linux 2.6.2 -- 5336 kernel compile error
 
I just installed gentoo with kernel 2.6.2-mm1. I downloaded the 5336 drivers and installed them, but the compile stops just before reaching 100% and errors saying that it cant find the kernel sources and that i need to use the --kernel-source-path extension. I use "--kernel-source-path /usr/src/linux" but that does nothing.

I dont know if that is the right usage of the extension, or if I need to do something different. I do know that that is the path to my kernel source.
I dont even know if that extension will solve my problem.

Im kind of at a loss and any info would be great.

Thanks.

The actual error says: "Unable to load the kernel module 'nvidia.ko'. This is most likely because the kernel module was built using the wrong kernel source files for your kernel; on red hat linux systems, for example, be srue you have the kernel-source rpm installed. If you know the correct kernel source are installed, you may specify the kernel source path with the '--kernel-source-path' command option"

Hope this helps.

Turtle 02-09-04 08:04 PM

well, I tried "--kernel-name=linux-2.6.2-mm1" and it compiles successfully. Thats good. But then I edited my XF86Config file, and now when i startx, it errors saying: "EE - failed to initilize the nvidia kernel. EE - ****ABORTING****. EE - Screens found, but none with usable configurations."

The screens are fine, so i just dont think my nvidia kernel got installed.

whig 02-09-04 08:17 PM

Check that the nvidia kernel module is loaded with lsmod and then modprobe it if not.

a^folken 02-15-04 06:22 AM

I have exactly the same problem with the kernel 2.6.2 and the Nvidia drivers 5336.
I also tried with --kernel-name=2.6.2, and I get exactly the same error.
So I tried insmod, the module can't be load maually because of a gcc version mimatch: i used gcc v2.95 to compile my kernel, i've actually the version 3.3.
I tried export IGNORE_CC_MISMATCH=yes before compiling the module , i get the same result.

i use linux debian sid and my vidoe card is GeForce FX5900XT.

Can someone help me?

666_1337 02-15-04 07:00 AM

recompile the kernel with gcc 3.3

a^folken 02-15-04 07:58 AM

I did it and now i can't load any module at all =( .


All times are GMT -5. The time now is 12:04 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.