nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   NVIDIA 1.0-5336 + kernel 2.6 + debian sid : doesn't work (http://www.nvnews.net/vbulletin/showthread.php?t=24719)

waju 02-10-04 07:10 AM

NVIDIA 1.0-5336 + kernel 2.6 + debian sid : doesn't work
 
1 Attachment(s)
hi:

i've installed debian sid, totally updated. i update to the 2.6 kernel (optimized for 686), i installed the kernel-headers and compile the latest driver 1.0-5336. it compiled perfectly, without any problem.

i reboot the computer to make all changes, but now the driver doesn't work. i've my computer configured to enter automaticaly into X (wiht Gnome), but in the 7 console (ALT+CTRL+F7), where X should appear, i've got the following message:

missing DISPLAY and console dialog could not be found
missing DISPLAY and console dialog could not be found

i enter then in text mode, and type "startx", but the X doesn´t appear, and I get an error.

I paste you here the XFree log as attachment. I hope you could help me.

regards

waju

Corona688 02-10-04 09:49 PM

The nvidia drivers actually appear to be working fine, but X can't find your mouse:

Quote:

<snip>
(**) Option "Protocol" "ImPS/2"
(**) Configured Mouse: Protocol: "ImPS/2"
(**) Option "CorePointer"
(**) Configured Mouse: Core Pointer
(**) Option "Device" "/dev/psaux"
(EE) xf86OpenSerial: Cannot open device /dev/psaux
No such device.
(EE) Configured Mouse: cannot open input device
(EE) PreInit failed for input device "Configured Mouse"
(II) UnloadModule: "mouse"
(**) Option "Protocol" "ImPS/2"
(**) Generic Mouse: Protocol: "ImPS/2"
(**) Option "SendCoreEvents" "true"
(**) Generic Mouse: always reports core events
(**) Option "Device" "/dev/input/mice"
(EE) xf86OpenSerial: Cannot open device /dev/input/mice
No such file or directory.
(EE) Generic Mouse: cannot open input device
(EE) PreInit failed for input device "Generic Mouse"
(II) UnloadModule: "mouse"
(WW) No core pointer registered
(II) XINPUT: Adding extended input device "NVIDIA Event Handler" (type: Other)
No core pointer

Fatal server error:
failed to initialize core devices

waju 02-11-04 10:31 AM

thank you very much Corona688, you've got reason: the problem was the mouse.

From /usr/share/doc/kernel-image-2.6.0-1-686/README.Debian.1st.gz

PS/2 Mice
---------
If your PS/2 mouse does not work, make sure that the modules psmouse and
mousedev are loaded.

i has loaded the module psmouse, but not the mousedev. now all is right!!

regards

waju


All times are GMT -5. The time now is 07:17 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.