nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   SuSE 8.2: "Failed to allocate config DMA context" (http://www.nvnews.net/vbulletin/showthread.php?t=24771)

maibaum 02-11-04 05:35 PM

SuSE 8.2: "Failed to allocate config DMA context"
 
I tried to install the NVidia graphics driver for my GeForce2 MX 400 on a fresh SuSE 8.2 install. The installation went fine, but X refuses to start with the new nvidia driver. This is the relevant (I think) part of XFree86.0.log:

(--) PCI:*(1:0:0) nVidia Corporation NV11 [GeForce2 MX/MX 400] rev 178, Mem @ 0xee000000/24, 0xf0000000/27, BIOS @ 0xefff0000/16
(II) Module nvidia: vendor="NVIDIA Corporation"
(II) NVIDIA XFree86 Driver 1.0-5336 Wed Jan 14 18:30:46 PST 2004
(II) NVIDIA Unified Driver for all NVIDIA GPUs
(--) Chipset NVIDIA GPU found
(**) NVIDIA(0): Depth 16, (--) framebuffer bpp 16
(==) NVIDIA(0): RGB weight 565
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xF0000000
(--) NVIDIA(0): MMIO registers at 0xEE000000
(II) NVIDIA(0): NVIDIA GPU detected as: GeForce2 MX/MX 400
(--) NVIDIA(0): VideoBIOS: 03.11.01.48.00
(EE) NVIDIA(0): Failed to allocate config DMA context
(II) UnloadModule: "nvidia"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

The driver and the kernel were both compiled using the same version of gcc (3.3 20030226 (prerelease)).

I would appreciate it if someone could point me into the right direction.

Lutz

maibaum 02-13-04 05:00 PM

[Solved] SuSE 8.2: "Failed to allocate config DMA context"
 
I found a solution to this problem in the following thread:

http://www.nvnews.net/vbulletin/show...threadid=16509

In short, I had to do the following before running the nvidia driver installation program:

cp /boot/vmlinuz.config /usr/src/linux/.config
cp /boot/vmlinuz.version.h /usr/src/linux/include/linux
cp /boot/vmlinuz.autoconf.h /usr/src/linux/include/linux
cd /usr/src/linux
make cloneconfig dep

I didn't think this was necessary, since I already had the kernel sources installed, but this worked for me.

Lutz


All times are GMT -5. The time now is 07:28 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.