nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   NVIDIA 2960 Drivers & RH 7.3 W/2.4.18-5 (http://www.nvnews.net/vbulletin/showthread.php?t=249)

XASCompuGuy 07-31-02 03:20 PM

NVIDIA 2960 Drivers & RH 7.3 W/2.4.18-5
 
I am posting this message as a bug report because I suspect the NVIDIA 1.0-2960 GeForce driver does not work with kernel version 2.4.18-5 and the lastest updates from Redhat's up2date service (as of 7/31/2002).

I'm running Redhat 7.3 with kernel version 2.4.18-5 and XFree86 v4.2.0 on a dual Athlon system with the GeForce 2 MX 64 MB AGP video card. I attempted to install the 1.0-2960 graphics driver with no success.

First, I tried
rpm -ivh NVIDIA_kernel-1.0-2960.rh73up.athlon.rpm
NVIDIA_kernel-1.0-2960.rh73smp.athlon.rpm
rpm -ivh NVIDIA_GLX-1.0-2960.i386.rpm
But it came back with an unresolved symbols error in NVdriver. So I got rid of the install with rpm -e ...

Then, I tried
rpm --rebuild NVIDIA_kernel-1.0-2960.src.rpm
rpm -ivh /usr/src/redhat/RPMS/i386/NVIDIA_kernel-1.0-2960.i386.rpm
rpm -ivh NVIDIA_GLX-1.0-2960.i386.rpm
But the unresolved symbols error with NVdriver came back. Again, I got rid of the install with rpm -e ...

Finally, I tried the tar files:
tar xvzf NVIDIA_kernel-1.0-2960.tar.gz
tar xvzf NVIDIA_GLX-1.0-2960.tar.gz
cd NVIDIA_kernel-1.0-2960
make install
cd ..
cd NVIDIA_GLX-1.0-2960
make install
The annoying error with unresolved symbols came back.

In all three cases, I have modified /etc/X11XF86Config-4 according to the README file and started X with startx only to jump back to the console with error messages stating the NVdriver is not present. (Of course it's not. It was never created successfully because of unresolved symbols.)

Of course, now it's a total pain to restore the system to working order, having to rpm -Uvh --replacepkgs --force XFree86-4.2.0-8.i386.rpm after removing the GL libraries and their symbolic links from /usr/lib and /usr/X11R6/lib/modules/extensions.

The NVIDIA FAQ mentioned that unresolved symbols with NVdriver probably means I have the wrong kernel headers installed. So, I downgraded from glibc-kernheaders-2.4-7.17 to glibc-kernheaders-2.4.7.14 with rpm -Uvh --replacepkgs --force options. I also made sure I have the kernel-source-2.4.18-5.i386.rpm in case making the drivers required it. That did not work.

My tech guy, a very good Linux guy with at least 3 years experience, concluded after testing the driver installation himself that these NVIDIA drivers will not work with 2.4.18-5. up2date changed the kernel header files or something in between. These drivers would have worked with an original installation from the RH 7.3 CD. The best bet is to simply wait for NVIDIA to release newer drivers. up2date updated basically everything on my system to date (7/31/2002).

Right now, I have reverted my system to before this NVIDIA 2960 driver fiasco.

I hope that whomever is having similar troubles finds this message and that this message finds you well.

Thunderbird 07-31-02 04:10 PM

It are not the glibc kernel headers that are used for the driver to compile but the headers from the linux kernel itself.

On RH 7.x the src is /usr/src/linux-2.4.X. Next to that there's a symlink linux-2.4 (or perhaps they still use a symlink called linux) to linux-2.4.X.
Likely that symlink still points to linux-2.4.18-3 instead of -5. If this is the case then it is logic that you get unresolved symbols since the 2.4.18-3 headers are used.

XASCompuGuy 07-31-02 04:49 PM

The link was pointing to the correct kernel--2.4.18-5smp. I even deleted the 2.4.18-3* directories.

sgls 07-31-02 05:46 PM

I have exactly the same problem.

I recently upgraded to RH 7.3 (default is 2.4.18-3 kernel) and reinstalled the nvidia drivers (2960 for Athlon) from rpm. That worked fine (much easier than when I first did this on RH 7.0).

I then upgraded the kernel to 2.4.18-5 from rpm and the nvidia drivers no longer worked. The nv driver works, but I can't be bothered to sort out the acceleration for it.

Luckily I didn't delete the old kernel so I'm using that.

This suggests it's not an install problem but a kernel module problem.

I'm hoping this will get fixed in the next kernel release or driver release.

Stefan

sgls 08-01-02 11:28 AM

In fact, I'd installed the rpms under 2.4.18-3 which doesn't put anything in the /lib/modules/2.4.18-5/kernel/drivers/video directory. Copying NVdriver there didn't help.

Reinstalling under 2.4.18-5 gave the module error messages reported above.

I've gone back to 2.4.18-3 again.

Incompatible kernel and driver. 1.0.2960 assumes 2.4.18-3 so this probably shouldn't be too surprising.

Stefan

rflanery 08-01-02 11:01 PM

I have 6 dual amd mp 1800+ systems all set up and working fine with the 2960 drivers and the Redhat 7.3 2.4.18-5smp kernel. I used the src rpms for the install of 2960 after using up2date to upgrade the linux kernel and header files to 2.4.18-5smp. So, I doubt the drivers are the problem.

rflanery

sgls 08-02-02 11:53 AM

rflanery is quite right. Serves me right for not using the srpm. (Upgrading headers etc... is not that bad really.) I'm keeping my 2.4.18-3 kernel around just in case though.

Stefan


All times are GMT -5. The time now is 10:49 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.