nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nvidia drivers uninstall after reboot (http://www.nvnews.net/vbulletin/showthread.php?t=24903)

Sideshow Bob 02-15-04 11:12 AM

nvidia drivers uninstall after reboot
 
1 Attachment(s)
Start with my configuration:

RedHat Linux 8
kernel version 2.6.2

Geforce MX2 32meg memory video card
driver version 1.0-5336
mainboard ECS K7vza

The problem is that I am able to install the new drivers, 1.0-5336, but during the installation, I get a "kernel tainted by NVIDIA" message. Xserver seems to run okay, but after rebooting, lsmod does not show the nvidia module running, and insmod reports the nvidia directory is not found. I reinstalled the drivers, and got a message they were previously installed. I suspect a driver conflict, but am not sure where to look. Any suggestions? Thanks in advance.

wardave 02-16-04 12:48 AM

Im sorry I dont mean to poke fun at your errors but tainted by nvidia LOL they should change that.


One entry found for taint.


Entry Word: taint
Function: verb
Text: 1 to touch or affect with something bad or undesirable <his good reputation was tainted by the scandal>
Synonyms besmear, besmirch, blur, cloud, defile, dirty, discolor, smear, smudge, smut, smutch, soil, stain, sully, tar, tarnish; CONTAMINATE 1

rednuht 02-16-04 07:47 AM

taint is fine
 
the taint message is the Linux kernel telling you the the NVidia drivers are not GPL'd (ie. you can not get at ALL the source)

As for the modules I have exactly the same problem, all was working before I upgraded from 2.4 to 2.6.2 and the new

/etc/modprobe.conf

has got the correct nvidia lines, very odd.

geowiz 02-16-04 09:44 AM

Modprobe
 
I had the same issue until I read that the new kernel loads modules using the major-minor numbers (not like old 2.4 kernel). So, the /etc/modprobe.conf needs to have alias char-major-195* nvidia as it's entry (NOTE the "*"). The nvidia module loads properly everytime now.

As a side comment - had the same issue with my usb module loading but the wildcard didn't seem to work so I punted and just put it in my rc.local file. (/sbin/modprobe ohci-hcd )

On the reboot, the nvidia kernel driver module is there, just not autoloading. Drivers are not deinstalled by Linux without your permission ;-)

Hope this helps.

Sideshow Bob 02-16-04 12:12 PM

Thanks for the replies. I added the alias line in the modprobe.conf file and rebooted, but still get the problem. I guess the taint message meant "t'aint gonna happen". Still looking for help.

geowiz 02-16-04 01:44 PM

Taint so
 
Don't worry about the taint message - it always shows up as the Nvidia graphics module is not GPL code. The module loads and runs ok with that "warning". It just lets you know that if you have a kernel problem, the kernel developers will NOT look at the debug or error if it is tainted ;-)

Check to see if the nvidia module is loaded after the reboot: /sbin/lsmod | grep nvidia , if not then can you manually load it? /sbin/modprobe nvidia (insmod doesn't work as well in 2.6.x as before -IMO)

If it doesn't manually load, then check if it is actually in the kernel modules directory ls /lib/modules/`uname -r`/kernel/drivers/video/nvidia.ko. If it isn't there then it was not installed properly. But, since it works when you "install", and it gives the taint message, it is almost certainly installed in the correct spot.

You did upgrade module-init-tools when you moved to the 2.6.2 kernel, right? The old modutils will not work in 2.6.x

With the module-init-tools and the wildcard alias in the /etc/modprobe.conf file, it loads every time.

Good luck

Sideshow Bob 02-16-04 02:12 PM

Okay, I am able to load manually so I just need to find out how to get the computer to load on reboot. I tried adding alias /dev/nvidiactl nvidia (possible misread), options nvidia NVReg_EnableAGPFW=1 NVReg_EnableAGPSBA=1 and alias /dev/nvidiactl* nvidia to modprobe.conf per another thread, no luck. Any ideas? Thanks for the help. BTW, I am using the updated version of module-init-tools-3.0-pre9.

geowiz 02-16-04 02:35 PM

punt ?
 
Well, to get it to go you can add /sbin/modprobe nvidia to the end of your /etc/rc.d/rc.local file. Doesn't resolve the underlying problem but should "force" the module to be loaded on boot. Good thing is that in *nix there's more than one way to skin the cat ...

Sorry we don't have THE fix but try the rc.local fix and get on to something more fun....... I'm off for a skate.....

Sideshow Bob 02-16-04 03:43 PM

It worked. Thanks a lot.

rednuht 02-16-04 05:57 PM

install again
 
ran the install again and now on reboot nvidia gets loaded and X/kdm starts fine very very odd.

and I did have alias char-major-195* nvidia line in my modprobe.conf and X log showed it failed to load
alias char-major-195.255

bizare, but hey it works now.


All times are GMT -5. The time now is 04:24 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.