nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Kernel API Version not matching Driver Version (http://www.nvnews.net/vbulletin/showthread.php?t=24908)

promd 02-15-04 12:47 PM

Kernel API Version not matching Driver Version
 
1 Attachment(s)
Hello LinVidia Gurus!

I have some strange issues with installing the Driver from nvidia.com to my Mandrake 9.2... When I install it I am no longer able to start my XFree86, It allways tells me that the Kernel driver version 1.0-4496 is not matching the Drivers version 1.0-5xyz. Sorry that I can't be more precise, but I just noticed that the logfile does not contain the errormessage. I can't reproduce the error, or better I don't want to do so, b/c normaly this ends up in re-installing the system. I tried to run the Nvidia installer with -n, --add-this-kernel and also with -eq , all of them lead to the same result. It's quite frustrating. I had a redHat9 running some weeks ago, and that worked perfect with the downloaded drivers...

Can someone help me? I try to update the driver, b/c I hope that my 2nd monitor will work like it did on redhat9. With the driver that comes along with Mandrake I can't make it work for some reason...Does anybody now a nice tool or a tutorial for DualHead configuration? (please don't point me to the Nvidia readme file, it's good, but it did not help me this time)

I really hope you know a way to help me....

Regards,
ProMD

Kernel Module 1.0-4496
Model: GeForce4 Ti 4200
IRQ: 16
Video BIOS: 04.25.00.27.00
Card Type: AGP

geowiz 02-16-04 09:17 AM

Version
 
Well, not sure about the error but:
The log indicates you are using 1.0-533x module not 4496. I would suggest that you download and 533x and reload the 533x nvidia module in Mandrake.
Mandrake uses the /etc/X11/XF86Config-4 for the config file. I wonder if you didn't edit the XF86Config file and that the two are not the same. Check that they are either the same or sym-linked.

BTW, I've only had to reload an OS twice (in 9 years of Linux) - both times the hard drive crashed. You should almost never have to reload the OS in Linux - it's not like the greasy M$ stuff ;-)

Hope this may be of some assistance.

promd 02-16-04 10:21 AM

1st: Thanx for the reply!

Ok, I admit that I'm a newbie on Linux...
But at least I know what a manpage is ;)
Downloading the 533x and bringing it into the mandrake system is exactly what I did - at least I thought I did....
I downloaded the .run and executed it. In the XF86Config-4 there was not much to edit, the driver string was "nvidia" before, and the Module Loadings were ok as well.

Nevertheless the .run was not able to exchange the module completely. If I understand the README from Nvidia correctly it's supposed to change all of the interfaces and drivers?

All is ending in the errormessage I tried to recall in the original posting (which states exactly what you figured out, the versions are not matching).

BTW: I belive that you don't have to reload the system, but you have to know how to fix it :-) [ I try to learn how, that's why I'm posting ]

Regards,
Martin


All times are GMT -5. The time now is 08:49 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.